Thunderbird email attachment option doesn't offer samba network access

Hi ubuntu-mate community!

I just run the last update available and since then when I compose an email in thunberbird, and click on attachment, I do not see anymore my network connection. I need to it to attach files from the NAS. It does show in the caja file browser. Am always connected to my NAS via samba. Am using 17.04. Did anyone else come accross this issue? Is there a way to fix it or do I need to re-install something? Will be grateful for your advise!

Sunny greetings from far away Mauritius!

When you say it appears in Caja, do you mean the sidebar that contains the bookmarks? Do you have the same sidebar of bookmarks in the open dialogue window that Thunderbird creates?

Yes, exactly. See screenshot attached.

No, it looks different. See screenshot attached. It looks different :confused:

Is there a way we can get those links into the dialogue window Thunderbird creates?

this is the screenshot of the dialogue window for thunderbird:

1 Like

Thanks for your helpful screenshots!

What do you see if you click on Other Locations?

I see this:

However when an email has an attachment and it's in my inbox, for example a photo, if i open the photo and go on save as I get all the options that are missing when I want to attach a file. (Those screens of Thunderbird that is file managers do not look exactly like CAJA).

So, I believe the next step is to see if you can reproduce this problem on stock Ubuntu. If you can, then it’s not a Caja/MATE problem but rather a Thunderbird issue that you have to raise upstream.

By upstream you mean where exactly? On the ubuntu forums? Can this be tested via a live CD?

By upstream I mean the Thunderbird bug tracker:

Yes, download the default Ubuntu live image from and do the testing.

Hi, I figured out another way to access my files and this works:
I go in caja on root > run > user > 1000 > gvfs
and there I can see my server to access files and attach them to my email. Maybe this can help some who have the same issue with thunderbird.

1 Like

when I access on root it says permission denied, are there any suggestion Dashy ?

Why are you accessing from root? This is not recommended.

I had the same issue with Thunderbird, Firefox, etc. when saving / downloading files to a network share.
The following method worked for me in Ubuntu MATE 16.10, 17.04 and works now in 17.10.

Use Gigolo and configure it as a Startup application - see
Make sure you install and configure it like described in the link above and configure you network shares (I’ve chosen to remember network shares passwords forever - you may check in the “Password and Keys” application - suppose this is safe).

Afterwards open a terminal:

  1. ls -d /run/user/$(id -u)/gvfs/*/
  2. pluma ~/.config/gtk-3.0/bookmarks
  3. paste following line(s) into the new file
    file:////run/user/1000/gvfs/smb-share:domain=<DOMAIN_NAME>,server=,share=<SHARE_NAME>,user=<USERNAME_FOR_THE_SHARE>/ <NAME_TO_SHOW_IN_CAJA>
  4. save the file

Can’t remember if a reboot is required (presumably not), but afterwards, I was able to save / download files directly to the network shares from almost any program (including Thunderbird, Firefox, Google Chrome).