Thunderbird Snap HDD Permissions

I'm migrating from an old MacBook to a Dell laptop from Costco. I've installed a .5TB SSD for boot and scratch partitions, and formatted the pre-installed 1TB HDD to Ext4 for longer term storage. Firefox that came with the Ubuntu Mate install seems to use the HDD for Downloads just fine.

Thunderbird on the MacBook was set up for POP mail because I want local storage. It was a newer version than the latest available from the Boutique or Software apps in Ubuntu 20.04.1 and that borked my attempts to import all the Tbird mail and settings in the massive Profile file. I eventually found a Snap for the current Tbird version, banged my head on the import until reading that Snap sets up its own directory for the Profile, and now it's working.

But: Tbird refuses to use my HDD Download folder, offering this friendly and highly detailed message:

In desperation I turned on all Permissions on the HDD and Tbird still pops the error, despite this:

For now I've set Tbird to use the SSD Desktop directory, but that's not viable long term. Anyone have ideas on how to get this working, or would it be better to start over with the latest Tbird from the official mozilla Tbird PPA? I read somewhere that Ubuntu or Mate has shifted to the Evolution app for email, but Tbird meets my needs and I'd rather not delve into a new app.

1 Like

just a thought,
change the perms to Downloads/ and .Trash-1000/ to 755 (I looked at my usb's dirs/perms).
Also, the top level dir ./ should be a:a not a:root, perms should be 755

1 Like

Thanks! :slightly_smiling_face:
I was excited about your idea of changing /media/a/HD.1TB to a:a but it made no difference. Root now owns /media, and everything below it is a:a now. Since the drive's empty I don't mind full r/w just until I get it working. The /media directory only has the one drive in it, so I also tried sudo chmod -R 777 /media and now ls -alR shows /media and everything below it as drwxrwxrwx but Tbird still can't access the drive or anything on it with its
Preferences->General->Files & Attachments->Save files to->Browse button. :expressionless:

Just now I tried plugging in a FAT format USB, and Tbird can't access that either. Guess I may need to try installing Tbird from the mozilla PPA?

@JohnW formatted a usb stick as fat32, saved some files in there. The went to Thunderbird (68.10.0), write a new email, click attachment, get files from the usb stick. All worked w/ issues. Note: I do not have the snap version, I have the usual "sudo apt install thunderbird" .

1 Like

You have try to adjust Snap permissions by

snap connect thunderbird:removable-media

If it does not work, then remove snap version with snap remove thunderbird and install deb-version instead using sudo apt-get install thunderbird .

1 Like

I use the ubuntuzilla/mozilla version of Thunderbird which is a repository, which I prefer. The only thing is updates take about two days longer to receive.

You can also install the ubuntuzilla/mozilla versions of Firefox, Firefox ESR and Seamonkey from this repository.

1 Like

Could it be possible that the drive is mounted read only ?

You may need to remount it read+write : ```
sudo mount -o remount,rw /partition/identifier /mount/point

1 Like

It may be that Thunderbird is reacting to your HD because it is plugged in via a USB port. All media is where removable storage is ordinarily mounted. I came across an issue like yours and solved it by altering my fstab file to mount my USB device upon boot.
Worked like a charm.

As an example, see /home/external below:

<file system> <mount point>   <type>  <options>       <dump>  <pass>
/ was on /dev/sda7 during installation
UUID=bb23307f-27f0-5b3d-a918-58e8b1efbea1 /               ext4    errors=remount-ro 0       1
/home/data2 was on /dev/sda6 during installation
UUID=bb23307f-27f0-5b3d-a918-58e8b1efbea1 /home/data2     ext4    defaults        0       2
/home/data3 was on /dev/sdb5 during installation
UUID=bb23307f-27f0-5b3d-a918-58e8b1efbea1 /home/data3     ext4    defaults        0       2
below was added on July 29, 2019
UUID=SF32B7AA74B52DCT /home/external                      ntfs    defaults        0       0
swap was on /dev/sda3 during installation
UUID=bb23307f-27f0-5b3d-a918-58e8b1efbea1 none            swap    sw              0       0
1 Like

Thanks for the followup, verifying that it's working differently on my system.

Hurrah!! :clap: :smile:
Fixed! :+1:

I did man snap to get some clue, then snap connections to see examples, saw thunderbird:home in the list and figured that's probably the boot SSD drive. I thought you meant thunderbird:removable-media would work for the thumb drive and I'd need to find the syntax for the HDD snap "plug" for that specific drive. To try a thumb drive again I typed your command into a terminal window. Out of curiosity before plugging in the thumb drive I tried to access the HHD from Tbird, and it's working fine now. Presumably also for a USB drive but I'll probably never use that, so I haven't even tested it.

So in reading a bit about this, I gather part of the sandboxing of snaps for security, is limiting system access to the absolute minimum needed. So now I'm wondering if it would be a good idea to limit Tbird to only the HDD/Downloads directory and if so how to do that.

The other thing I'll need to do now is figure out what the HDD directory ownerships and permissions should be and set them back to that. For starters I'm going back to 755. To save time on this new empty drive I'll try just using gParted or Disks to reformat the drive and let the system do it.

Bottom line for now is: Thank You. I hope the Topic of this help request may make it easier for others using snap for the new Tbird, to find this simple solution.

1 Like

I was sorely tempted, since as noted the new version is required due to migrating from that version on Mac makes nightmares with importing Profiles to the older version. Being a timid newbie though, I like the idea of a Canonical Snap with the hope of maximum compatibility and safety. Maybe safer to go with dailys though? Anyway, now that it's working I'm reluctant to start over.

Thanks for the idea. I realized a quick way to check that is simply open Nemo in my default 2-Pane view and try copying something to the HDD. Having read your suggestion first, I tried that before the snap connect command and it worked fine. This reinforced the notion that it's a Tbird issue, in this case related to using the snap version.

Thanks for the idea. I'd wondered why it was showing up in /media when none of the SSD partitions are. Still don't really understand that, because it's actually an internal SATA drive. Maybe anything not on the boot drive is considered external to the system? That might make sense given the snap connect command working with the removable-media plug. Strange stuff from where I stand, but it sure is nice to have working now thanks to all the help! I'm glad to have at least 1TB to fill up with Ffox & Tbird downloads before moving chunks to my lumbering external 5TB archive HDD. Next year maybe Santa will bring me an inexpensive 2TB external USB 3.1 SSD. :wink:

Perhaps you added the hard drive found in /media/a/HD.1TB after installing Ubuntu MATE, I don't know. You might want to investigate your fstab file to allow this hard drive to be automatically mounted. To edit it you will need super user permissions, pkexec caja, should do quite nicely then navigate to /etc/fstab .

Please see the following for more information about the fstab file -

Its a bit long but very useful. Good luck JohnW.

Thank you for the followup. It's frankly amazing how so many knowledgeable people like you have stepped up to help everyone. I'm appalled at how long it's taken me to notice your kind reply and send this response. Also at how far over my head your suggestion has flown, despite reading it several times. By way of explaining my delay, the Costco Dell is going back (several deal breaker physical design issues). So now I'm trying to get Ubuntu MATE 20.10 working on the 2010 MacBook (just posted a pathetic cry for help on that).

So long story slightly shorter:

  1. My limited brain power is now directed to getting MacBook onto MATE 20.10 today.
  2. The 1TB SATA SSD was working just fine and MATE was running like a gazelle, so I'd have been reluctant to tempt fate by messing with fstab.