Touchpad corner right click doesn't work

Hello. I just upgraded from 20.04 to 20.10 and I have an issue with touchpad. I have an old notebook (Toshiba Portege M750) and I'm satisfied with Ubuntu Mate on it. The notebook has an older touchpad, which doesn't support multi-finger gestures. The hw buttons are too noisy for me, so I use tap-to-click and the right-bottom corner works as right-click. After some Mate version (I think it was 19.10) the corner right click stopped working. I figured out that the problem was that Mate used xserver-xorg-input-libinput as default input handler for touchpad and not xserver-xorg-input-synaptics. So the solution was to install synaptics and the corner-right-click worked as before. This was until update to 20.10. After the update the mouse pointer froze and was not usable. I uninstalled (purged) the xserver-xorg-input-synaptics package and after reboot the touchpad worked again. But without the corner-right-click option. Some suggestions on the net were to use gnome-tweak-tool, buth this method doesn't work on Ubuntu Mate.

Is there any way to configure/enable corner-right-click in Ubuntu Mate (some gsettings?), or through libinput, or some other way to enable the corner-right-click feature?

Thanks for answers and suggestions.

Ok. New hope on the horizont.

I've found that with xserver-xorg-input-synaptics installed the mouse poiner works on the login screen. After login it freezes. So I logged out, and it worked. That's strange. But more strange was, that after loging in again, the touchpad worked, with the corner-right-click feature. I'm happy now. No need for muscle memory retrain. Maybe som package I installed messes with cursor. Will investigate.


@jezek, glad you figure it out yourself. In my case, the touchpad would stop working each login and I had to reload psmouse module. I then removed synaptics and let libinput handle and it resolved issue. If you say for your case synaptics works, you may want to remove libinput in case you see touchpad freeze at login/reboot later .

@saivinob, thank you for suggestions. I will investigate again when reboot will be needed. Unfortunately I rarely reboot the notebook (always suspend), so it may take a while. All findings will be reported here.

I found out, that when I login using ENTER key after filling password, the mouse stops working. When I login using mouse click on the arrow, the mouse keeps working.

Note: Haven't tried to remove libinput yet.