Touchpad is not working on my Asus R417N

Greetings. This is my first post.

I bought this Asus R417N, which is a really cheap computer which that comes with Windows 10 installed. However, I decided to change my operative system in this laptop because I’m kinda tired of Microsoft and also because Linux is really cool for learning some computing skills.

I downloaded the latest ISO image aviable in the website (17.10), and now that I have deleted my Windows 10 OS and also have completely replaced it with Ubuntu Mate, I find out that my touchpad is not working correctly. Every time I turn on my laptop I’m able to use my touchpad for like 10 seconds and then the arrow gets frozen and I have to connect my USB mouse in order to be able to fully use my computer.

I thank you really much for your help.

Hi @Mauricio_Bautista,

have you done all your updates?, take a look at the following guide and then get back to us if it doesn’t help. :smiley:

Hi again. Thank you for your help.

I have updated everything according to what is suggested in the link you gave to me, including the drivers and have also installed all the synaptics packs.

I have been analyzing this problem and it seems like the touchpad driver gets deactivated, but the system is not realizing about that and when I open the system > preferences > hardware > mouse, touchpad appears as if it was enabled.

I’ve also tried it with the sudo nano /etc/default/grub, and changing the line with quiet splash with

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i8042.kbdreset=1”

Have also tried this procedure with :


None of this commands has worked :frowning:

According to what i have found on the web, I have been able to see the name of the hardware of my laptop, which is the next one:

mauricio@mauricio-E402NA:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PixArt Microsoft USB Optical Mouse id=14 [slave pointer (2)]
⎜ ↳ ELAN1200:00 04F3:3045 Touchpad id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Asus Wireless Radio Control id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ USB2.0 VGA UVC WebCam: USB2.0 V id=10 [slave keyboard (3)]
↳ Asus WMI hotkeys id=12 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

¿What should I do now?

Hi @Mauricio_Bautista,

there are some suggestions here which may help you, I don’t have one myself so good luck: :smiley: