Touchpad not recognized on new Lenovo Ideapad 3

Lenovo ideapad 3-15IIL05 Laptop - Type 81WE

The touchpad is not recognized by Mate 20.04 or 20.10
I'm told it uses Elan drivers but cannot yet confirm.

Any help would be greatly appreciated. I'm a long time Mate user who just bought this laptop and desperately want to get it off Windows 10.
Many thanks!

How old is this laptop? If it's a recently and new released laptop then all i can advice is to not to by the latest and newest laptops or pc's, especially since it's possible they ship hardware of which no drivers have been baked into the kernel of a linux distro or at least not yet. Linux kernels run about six months behind.

You could try to install xserver-xorg-input-synaptics reboot and see if that works.

1 Like

Brand new. Well, I guess I'll just have to wait 6 months, then. The xserver command will have to wait, too, because I ran it off a live usb to test if it would work before installing it. I can't afford to take a chance that it won't work. Anyway, thanks very much for the input.

Not sure if this will help, but I had the same problem with my touchpad with Parrot OS early on (an older HP laptop). The drivers were not on the install media but where and did work once I installed the program. I had to use a wireless or USB mouse to complete the install. It still would be taking a chance though, as the only way to find out for sure if t will work after the install is to do the install.

1 Like

Please see -

and also -

which was referenced in the first suggestion. Good luck @bruc33ef

1 Like

@bruc33ef, I have the same problem on the same model laptop, running Lubuntu 22.04. Have you found a solution? I can use a mouse, but I like having the option of going mouseless.

I still have not found a solution even after upgrading to 21.10 and searching Google periodically. There are lots of supposed "fixes" out there but none of the ones I've tried work and others, eg, messing with the kernel, are beyond my comfort level.

Open Termninal and follow steps.

  1. sudo su
  2. apt update
  3. apt autoremove
  4. apt upgrade
  5. apt upgrade
  6. apt install build-essentials -y
  7. nano /etc/default/grub

(Edit “GRUB_CMDLINE_LINUX_DEFAULT to GRUB_CMDLINE_LINUX_DEFAULT= “quiet i8042.nopnp=1 pci=nocrs”)

  1. update-grub
  2. apt install git
  3. git clone GitHub - pavlepiramida/elan_i2c_dkms: Updated kernel module to fix touchpad detection on the Ideapad S145.
  4. apt install make dkms
  5. cd elan_i2c_dkms
  6. dkms install
  7. reboot
1 Like

Finally did it. Worked! Many thanks!