Trackpad stops responding in Ubuntu Mate 20.10 beta

I just reported this bug here:

a couple of minutes after boot, the touchpad stops responding (can't move the pointer, but the buttons are still responsive)

Machine: Thinkpad T460s
Kernel: 5.8.0-23-generic #24-Ubuntu
OS: Mate 20.10 beta

The Trackpoint (the nipple in the middle of the keyboard) and external mouse continue to function. The trackpoint however, moves much slower than usual.

EDIT

Restarting lightdm.service fixes the problem temporarily. However, shortly after logging back in the touchpad stops responding again.

Hi @jonpolak :slight_smile:
Try to share some output from the dmesg command with us :slight_smile:

The best would be to wait the touchpad stops working, directly get the output of this command.
Its probably a driver that get loaded and is not the best for the touchpad.

@jonpolak,
Thank you for bringing up trackpad response issue. In my case, immediately after logging in the trackpad is not responsive. One (only?) way to recover is to reload psmouse. I do as below.

sudo modprobe -r psmouse
sudo modprobe psmouse

@jonpolak, I managed to fix my issue by uninstalling synaptics driver and letting libinput to handle trackpad. Synaptics is not available in 20.04 install running on same machine and no issues with trackpad. In case you do not have libinput, install it.

sudo apt remove xserver-xorg-input-synaptics
sudo apt install xserver-xorg-input-libinput

I also created a symlink for 40-libinput.conf in /etc/X11/xorg.conf.d although it may not be needed (not present in 20.04).

sudo mkdir -p /etc/X11/xorg.conf.d
sudo ln -s /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/

A reboot is required.

@saivinoba thank you. this works. I removed synaptics NOTE libinput was already installed. As you pointed out, there was NO NEED FOR SYMLINKS.

This resolves the issue.

1 Like

@olek here is the dmesg immediately after the error occurred (very shortly after logon)

The other logfiles were also collected and appended to the bugreport see the other comments made at around the same time as #35

1 Like