Transfer speeds rapidly decline


I am running into an issue where my transfer speeds decline rapidly. Small and large files. I can’t pin down the root of the issue.

For example, here is a transfer of a 38GB file. One drive to another drive on the same computer.


Over time:

What I did not capture is transfer speeds declining to the 300MB/sec area, wasn’t fast enough didn't see it until the end of the transfer.

Screenshots are using Caja. I’ve also tried Thundar but have only gotten SLOWER speeds.


multiple Solidigm P41 Plus 2TB M.2 2280 PCIe 4.0 NVMe Gen4 and an Intel 670p

This is reproducible transferring to other drives i.e. not just A to B but all C to B or C to A and vice versa

The above is all one the same computer.

I've tested copying over the network (wired) just for the sake of testing and I run into the same issue, starting at 80MB/sec dropping to 26MB/s

Does anyone have any guidance or advice?

Appreciate the help.

EDIT: I don't recall of the P41 Plus NVME are DRAM-less. In such case would be happy to receive advice on caching techniques regardless.

can you benchmark "General Backup" with the disks app?



You are not alone by noticing HD transfer rates decline. I am afraid, that is not an issue, but the way things work :frowning: IMHO our equipment is not optimized for a bulk data transfers but for a lot of (relatively) small reads and writes.

As far as I can judge high initial speed is due to a lot of buffering and caching involved. Buffering and caching do not work well with bulk data transfers. And their effect is that they report a finished HD write transaction as soon as data are put down in a buffer/cache and not actually written onto media. That is why there are huge transfer rates shown.

On the other hand, as soon as buffers and caches are overflowed with a stream of non-reusable bulk transfer data we do see what is (very likely) just pure physical transfer rate.



No, they don't.

Your transfer rate is a constant 833 MB/s . This is the physical limitation of your storage medium connected to, and in combination with, your motherboard.

It is exactly what @ugnvs describes:

Your copy command is completely oblivious to the buffering that the kernel is doing and has no idea that it is filling a write buffer in RAM instead of writing directly to disk.

This makes it think that the transfer rate is much much higher than it really is, because RAM is much much faster than NVME/SSD/HDD.


Just to add:

The rates you see (1.4 GB/sec and 833 MB/sec) are the average over the total transfer. Actual speeds vary at any given moment. These numbers are the total bytes transferred divided by the number of seconds since the job started.

If you want to know your maximum burst transfer rate (the one that storage mfrs advertise) go to Applications -> Accessories -> Disks

In the upper right hand corner of Disks is three vertical dots. Click on that and select Benchmark. Follow the instructions and it will give the transfer speeds and latency.


I may have convoluted the post...a lot. Here's a 5 min clip. These drives are rated much faster than the results.

Product Spec - 2TB model. One of the drives is operating PCIe 3, so I understand a performance haircut but still.

I don't run into these speeds on windows, they are higher

I suppose the issue then is not declining speeds but less than expected results

Thanks for everyone's input, I ended up realigning/repairing the filesystem and speeds improved considerably.