Tried to install Mate but it stayed in try it mode

Hello folks.
Today, I replaced Windows 10 with Ubuntu Mate. The process went well, but at the end I got a message that i needed to make an error report and would I like to do that now. So, apparently Ubuntu did not install completely. Whenever I log out, nothing is saved on Ubuntu as far as passwords and other adjustments are concerned. Yet something was saved to the disk because whenever I boot up Ubuntu comes up, but it is the installation part that boots, not the OS. I can use the PC in this mode, but I just cannot save anything. Since I am not used to Linux I don't know how to check that out. An error report was made and apparently send in to Ubuntu, but I am not sure. I can use the PC in try me mode, but I just can't save anything. The options I have on my screen are: Install Ubuntu Mate 24.04 LTS and the Home Icon.
My laptop is an Acer Aspire E15, an older one. The drive is a mechanical 256 Gig that is original to the PC. It ran Windows 10 fine.
Any help would be appreciated as I cannot now go back to Windows 10 as I don't have the installation boot media. I used a 15 GB USB drive in conjunction with Ventoy to install it.
PS. I should say I am stuck in the live user mode. I tried to look up the version of Mate I installed, but don't know how to do that on Linux yet.

1 Like

Welcome @nearlysociable to the community!

1 Like

Hi, @nearlysociable (David L.) :slight_smile:

At the end of your message you wrote:

However, considering that earlier in your message, you also wrote that "The options I have on my screen are: Install Ubuntu Mate 24.04 LTS and the Home Icon.", I assume that you tried to install Ubuntu MATE 24.04 LTS ("Noble Numbat") and therefore I've added the tag 24-04-noble-lts to this discussion topic (and I've also added the Acer and installation tags).

I agree with your assessment that you're still in Live User mode. So, the first question I would ask is: did you remember to remove the USB flash drive from your computer at the end of the installation of Ubuntu MATE 24.04 LTS ("Noble Numbat")? If not, then what seems most likely is that your computer is always booting from the the USB flash drive that has the Ubuntu MATE installer and the Ubuntu MATE "Live environment", instead of booting from your (traditional) hard drive to where you (supposedly) have installed Ubuntu MATE. So, my suggestion is to:

1 - Shut down your computer.
2 - Check if your USB flash drive is still inserted in your computer.
3 - Remove the USB flash drive from your computer if it is still inserted.
4 - Power on your computer and see if it boots normally.

I hope this helps :slight_smile:

1 Like

I did all of the above three times, and that is what makes this so frustrating. All I can do at this point is click install, let it run and if an error shows up at the end of the process maybe that will shed more light on this. The installer is apparently on my hard drive, otherwise when I boot up it would not boot up to it without the USB drive being engaged. I will report to you the error findings.

Hi again, @nearlysociable :slight_smile:

Indeed, it must be very frustrating having done all that three times already, without success :frowning: After booting from your hard drive, can you try to open a MATE Terminal window ("MATE Terminal" is available from the Ubuntu MATE Menu -> "System Tools"), run the following commands inside that Terminal window and post another message in this same discussion topic with the output of the commands, please?

cat /etc/fstab


df -hTP

lsblk --fs --paths | grep --invert-match '/snap'

Hi there. You know RIC I appreciate the suggestion and willingness to provide help, but for me, it is too much of a rabbit hole. The Linux installer should just work on any system as Windows does. So I simply whipped up the media creation tool for another PC and went back to Win 10 and have had no problems. Thanks so much and take care.

1 Like