Trouble setting up Brother wireless printer

Newbie Linux user here. I've installed Ubuntu-MATE on a MacBook 2,1. All I want to do with it is check email, do Google searches etc... But, I also need to print sometimes.

I have a Brother MFC-J480DW. I had to find the drivers and miraculously they got installed last night. I printed a test page and everything was good. This morning, I tried to print again and the printer wasn't even set-up anymore. There was no printer installed anymore, So, I tried to reinstalled it. I got it reinstalled, but it won't print. The test page never gets to the printer I get a message that the printer might not be connected. Any ideas on how to fix this? Please dumb it down. I just started with Linux. Oh yeah, I ran the trouble shooter. It couldn't fix the problem. Thanks in advance.

Did you use the driver install tool from the Brother Support website (

If so, when the install script asked if you were going to specify the device URI, what option did you use?

Hi rasmith1959 I found the URI: lpd://BRWD80F9967B04D/BINARY_P1
and used that. I can supply any other information if it'll be helpful. Thanks for helping.