Trouble upgrading from 16.04 to 18.04

update-manager didn’t show me the new version so I tried /usr/lib/ubuntu-release-upgrader/check-new-release-gtk and got the following error:

:~$ /usr/lib/ubuntu-release-upgrader/check-new-release-gtk
/usr/lib/ubuntu-release-upgrader/check-new-release-gtk:30: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version(‘Gtk’, ‘3.0’) before import to ensure that the right version gets loaded.
from gi.repository import Gtk
WARNING:root:timeout reached, exiting


Hi camiller,

does this help at all?:

See also:


1 Like

Doesn’t help for me, I’m on 17.10 and can’t upgrade…

On 17.10, the Software Updater also doesn’t tell me that UM 18.04 is available. Had to start it manually with:

update-manager -cd

It’s currently downloading packages.


Thanks! That worked for me!

Brilliant, working for me, thank you!

Doesn’t the ‘d’ flag get the development version?

I think the error is because I have two different versions of gtk

Doesn’t the ‘d’ flag get the development version?

Yes. I thought that maybe for some reason the Updater thinks 18.04 hasn’t been released officially yet.

I think the error is because I have two different versions of gtk

I’m not sure it should matter. Theorically, the check-new-release-gtk software that you have on 16.04 should use Gtk2. It’s possible though that it is Gtk2 but tries to run as Gtk3 because you have both versions installed.

In any case, does it work with the command I gave?

It seems to be working, downloading now

1 Like

Thanks terzag and camiller, this fixed the issue for me too.

I had to change to main server and back to < Area > Canada server and then do ‘update-manager -cd’ I got working now.

For reference, this particular error is actually harmless. It’s a message aimed at the developer to be explicit which version should be used (it’s okay as it’s using GTK3 anyway)

Terzag, When I try your command all it tells me is that “The Software is up to date”, but I am still on 16.04. I tried wolfman’s walkthru. It is currently downloading packages, but I have a sneaking suspicion that it is driving towards 17.10. Once the download is complete I’ll know for certain.

Now that development for 18.10 has started, it’s probably a bad idea to use the -d option with update -manager. Have you tried with only the -c option?

Running the update manager command did not work for me.

So I was correct about the version before. Using Wolfman’s walkthrough pulled down 17.10 for me. I have no idea why. It was as if the updater did not even know 18.04 existed. Well, for whatever reason once 17.10 was installed, once I rebooted it would not read input from any of my peripherals. Not one. So I had to boot into Windows (yuck), and setup a USB with 18.04. I did a wipe and install and am now on 18.04. It works fine.

One problem I noticed is that my wifi had no drivers. Why I had to hook up an ethernet cable to get MATE onto the internet boggles my mind. Now it is time to start the crawl of re-mounting my drives, reinstalling all my drivers, and reinstalling all my programs. Owell. The Updater was a nice fantasy at least.