Try to restore Ext4 Partition after Dual Boot Install

Hi team,

I have installed Ubuntu+Windows7 in my notebook, but my Windows crashed (ohh!) and I had to reinstall and I upgraded it to Win10 version
After that I boot my notebook using the Ubuntu Mate`s DVD, and the usual commands that I used to repair the grub:

sudo fdisk -l
sudo mount -t ext4 /dev/sda4 /mnt
suo grub-install --root-directory=/mnt /dev/sda

But when I typed the command ~sudo mount -t ext4 /dev/sda4 /mnt~ I received the error msg

wrong fs type, bad option, bad superblock on /dev/sda4,
missing codepage or helper program, or other error

And when I open the $gnome-disks I saw this screen with my sda4 totally free :scream:

lol I dont know what I did wrong, I did it thousand times and all times were successfully
I dont have any special files in that partition, but I would like to repair (if it is possible). Is there any chance to repair?

Thank you

Hopefully gnome disks is misreporting. You should be able to open your linux partition in Caja from the live DVD to confirm that something is there.

Edit: Noticed in your screenshot sda4 is a extended partition, not a ext4 partition. This is why your getting the wrong fs type error. Run sudo fdisk -l in the terminal to find your Linux partition.

The procedure I use to repair Grub from a live DVD differs slightly from yours.

For example:

sudo mount /dev/sda1 /mnt

sudo grub-install --boot-directory=/mnt/boot /dev/sda

1 Like

Did it ask you about any formatting choices during the reinstallation?

Hi @orschiro! Yes! I’ve made a clean instalation of Win10 and when I was asked about the formating, I selected the NTFS partition. I’m sure of that

Hi @steven,
I’m not with my notebook right now, but I’ll try as soon as possible, but I remember that I used the ext4 but when I run the sudo fdisk -l the command returns to me no File System for sda4

Thannk you guys

Very strange. If you definitely not touched your ext4 partition but only your NTFS, then you should be able to mount it from your live image. And if that one is empty, well, then I am afraid it is…

Have you already tried a data restoring program?

Hi guys,

Sorry, but I booted the Live CD with my language (portuguese), but as you can see the sda4 partition is "extended" not ext4 anymore :frowning:

And when using Caja, it shows only the NTFS partition

Is there a good software for data restore?

Thank you

These might help you:

1 Like

Looks like your Linux partition has been deleted. After you recover your data, and reinstall, I recommend you consider making a system wide backup with Clonezilla. It’s capable of backing up and restoring both your Linux and Windows partitions. In addition, you should also have a scheduled backup of your data. Deja-Dup and rsync both work well for this.

1 Like