Turn Login screen back on

After installing MATE (great DE, love it) 1604, can’t change the login options. This laptop is meant for a few people using it, so I chose “log me in automatically”, but would like to change my mind, but there is no option for it in any gui. Beyond that not sure what to do.

I’d like to just change the option to “require password” which I know I can do in other gnome systems, and in KDE is under “users”.
No idea how to find or change it in MATE 1604.
Thanks.

Hi

I think this is the screen you want:

Find it in System -> Administration -> Users and Groups
or System -> Control Center -> Administration -> Users and Groups

Yes that is what I'm looking for but it's missing this option for auto login to be turned off:

It’s also not part of the Advanced settings either.
I do feel kind of dumb because I’ve been using ubuntu for almost 10 years, and for the life of me I can’t find the simple Login option for it… is it just me?

I think you’ve done something unusual with your install.
I’ve checked across machines and themes and that window should be named “User Settings”, not “User Accounts”.
The window in your screenshot looks like a typical gnome package. Fewer options.
Anyway, doesn’t clicking that slider next to “Automatic Login” work for you?

Ha - sorry, should have been more specific - the screen shot was from google. The slider is what I’m used to in ubuntu and this is my first run at Mate.
My screen is exactly same as yours, and I’m simply just looking for the option to turn the login screen back on.

(sorry, I’ll be more specific - I don’t want to confuse the situation the above shot is what I’ve normally used for this in other installs).

snip

That answer was not for 1604.

In that case, if the window you see is the same as mine, click the "Change" button on the line that reads "Password: Asked on login", then in the window that opens:

Uncheck the box telling it not to ask for password on login at the bottom.

The slider is what I’m looking for, or at the very least some terminal command to accomplish this like in a TRUE FALSE sense - that would be fine too.

I think I’m more wondering where a brand new user would find this setting and could they find it if they were new to Linux or MATE? There’s no “Login” in Control Center is more what I’m trying to point out.

I’m loving MATE but just want to make this better for those behind me too and I’m a linux advocate in a Windows only community (I’ve switched work computers to ubuntu or Mint for most machines, but they simply tolorate it). I’d hate to have to answer them “there is no option”.

BTW thanks ouroumov.

Oddly enough, it was unchecked. I’ll fiddle with that.

I believe that changed it - I wasen't looking closely and even though it was unchecked, it said "don't ask for password on login". User screen said it was on, password screen said it was off. In changing that, it turned it off then back on and everything was right. Rebooting now ....

Nope. Didn't go to login screen at at. Control Center says Password asked on login. Password screen "Don't ask for pw on login" is unchecked.

Yeah, I think we might have a bug on our hands here.
Try and add another user account, see if that changes something.

SOLVED

Upon only adding a new user, and deleting the current user, did the login appear on reboot. Simply adding another user did not clear the issue. Once the original user was deleted, it would welcome with the login screen.

Thank you ouroumov.

Possibly a tad bit unnecessary, I’ve found that a new password needs to be set when toggling the “Don’t ask for password at login”.