Turn off Bluetooth by default


#1

This tutorial discribes the method I used to disable Bluetooth in Ubuntu Mate 16.04. To disable Bluetooth in Ubuntu Mate 17.04, please scroll down to post No. 8 for the correct method.

To turn off Bluetooth by default in Ubuntu-Mate 16.04

Open the Terminal and run the following command:

gksu pluma /etc/default/tlp

Find the section:

# Radio devices to disable on startup: bluetooth, wifi, wwan.
# Separate multiple devices with spaces.
#DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"

Edit the last line to read:

DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"

Example:

# Radio devices to disable on startup: bluetooth, wifi, wwan.
# Separate multiple devices with spaces.
DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"

Save and close the file.

You also need to stop the Blueman Applet from loading at startup as it will turn on Bluetooth when it loads. This can be done by unchecking it in Startup Applications Preferences.

The next time you reboot Bluetooth should be disabled.


Help - Need permanent disable for some features
#2

Interesting, TLP is installed by default? I didn’t know that…


#3

Does it come installed in Ubuntu Unity too? I wonder if TLP is responsible for the bad performance I had in games under Ubuntu MATE, that didn’t happen under Unity. What about thermald?


#4

thermald is installed by default on Ubuntu Unity.


#5

You could test that by stopping tlp from the command line before starting a game

sudo service tlp stop


#6

I tried to follow the guide, but my tlp file is empty. I`m new to Ubuntu Mate and wanted to disable Bluetooth. I’m using the lastest version of the S.O.

What am I doing wrong? :frowning:


#7

Are you on a new install of 17.04 (i.e. not upgraded from an older version)? I believe I saw that TLP was removed from the default install of 17.04, so you’ll need to install TLP with sudo apt install tlp first.


#8

I just completed a fresh install of 17.04 today, and it appears that you are correct, TLP is no longer included.

I saw no reason to install TLP at this point, so I disabled the Bluetooth service by running the following command in the terminal.

sudo systemctl disable bluetooth

This will survive a reboot, and the blueman applet did not load on startup.

To check if Bluetooth is enabled run

systemctl is-enabled bluetooth

To enable Bluetooth again run

sudo systemctl enable bluetooth

After disabling Bluetooth as shown above, the service turns off on the next reboot, or on the next stop event. The same goes for enabling Bluetooth again.

To manually stop Bluetooth run

systemctl stop bluetooth

EDIT May 15, 2017

The above method does not work on Ubuntu Mate 16.04 unless you also disable TLP.

sudo systemctl disable tlp

However if your using a laptop you may not want to do this due to power saving considerations.


#9

Exactly, I am on a new install and didn’t have TLP installed. The systemctl commands worked and I now have it disable. Thank you both for your help! :slight_smile:


#10

Glad it worked for you. Welcome to the forum Khan.


#11

I’ve just used your method in MATE 18.04 and works flawlessly. Thank you so much!


#12

That’s good news. Welcome to the forum @nmsalgueiro.