[Tutorial] Sounds during boot up , shutdown , reboot


#1

In this tutorial I am going to tell you how to properly activate the sounds I mentioned in the title .

  1. Install libcanberra (if not already installed).
    1.1 In terminal .
sudo apt-get install libcanberra-pulse

*2. Install a sound theme .

2.1 They can be found in software center.
2.2 They can be found on search engines (search for linux sound themes).
(For installation tutorial from internet see this.

# Lets use Sonar sound theme from here.

Due to a bug in canbbera the sounds have to be in default theme folder (freedosktop)

*3. Now lets copy our startup sounds from the sonar sound theme to freedesktop sound theme . :

sudo cp /usr/share/sounds/sonar/stereo/system-ready.oga /usr/share/sounds/freedesktop/stereo/system-bootup.oga
sudo cp /usr/share/sounds/sonar/stereo/system-shutdown.oga /usr/share/sounds/freedesktop/stereo/system-shutdown.oga

3.1 This would work with any “.oga” file as they are named “system-bootup” and “system-shutdown”. Also they have to be in /usr/share/sounds/freedesktop/stereo/ folder

*4. Enable the systemd canberra services

sudo systemctl enable canberra-system-bootup.service
sudo systemctl enable canberra-system-shutdown-reboot.service
sudo systemctl enable canberra-system-shutdown.service

*5. On next reboot you should have those sounds . Feel free to ask if something isn’t right .


#2

i am getting errors galore! i installed EVERY package in synaptic relating to canberra! nothing works. here is what i get:
[email protected] ~ $ sudo systemctl enable canberra-system-shutdown-reboot.service
Failed to execute operation: No such file or directory
[email protected] ~ $ sudo systemctl enable canberra-system-bootup.service
Failed to execute operation: No such file or directory

Please help