Ubuntu 17.04 Wifi Problem (nothing loads although Wifi shown as connected)

I used Ubuntu Mate since 16.04, worked great through 16.10 but I broke it when I tried to upgrade it to 17.04 beta. Never mind, I decided to install Xubuntu 16.10 on other partitions to try something new, which turns out not bad. Upgraded Xubuntu to 17.04, Wifi issues occurred, where Wifi is shown as connected but I cannot browse any site, cannot update/upgrade using "sudo apt update/upgrade ", etc.

I have searched for days and nights and tried the following methods:

(1) adding
[device] wifi.scan-rand-mac-address=no
to “/etc/NetworkManager/NetworkManager.conf”
No improvement.

(2) adding as DNS, most sites work but local sites (*.hk, even www.google.com.hk) may not work.

(3) using 4.11 AMD64 RC7 kernel.

The problem should be related to DNS because it’s fine when I pinged with IP addresses. I thought maybe the update from Xubuntu 16.10 to 17.04 caused the issue, so I fresh install Ubuntu Mate 17.04 (reformatted the original Ubuntu Mate 16.10). The Wifi issue still hit me in the face after this fresh install, driving me crazy. The problem still exist as at today.

I think it could be this bug (though not strictly WiFi-related, more of a DNS issue).
Anyway, I hope this gets sorted out quicker than the infamous network manager WiFi issue…

Ah, I saw that post too. Do you know if there is any workaround for it? Thank you.

From the bug report:

What I have to do is go and shutdown systemd-resolved (sudo service systemd-resolved stop) and edit /etc/resolv.conf to point to (my router) instead of

How could I miss that? :frowning:
I’ve tried that too but in vain. Thanks anyway!

I tried again shutting down systemd-resolved (sudo service systemd-resolved stop) and edited “/etc/resolv.conf” to point to (my router’s IP, which is not as the one who reported in the bug report; stupid me :sweat:) instead of Now it seems to work!

But I have to shut down systemd-resolved every time I boot. Is there anything to shut it down permanently?

If the problem can be solved, I will continue to use the marvellous Ubuntu Mate again.

Thank you!

I had the wifi problems with you describe in 17.04 which was solved by an update on Friday. Now it works properly.


According to upstart - How to enable or disable services? - Ask Ubuntu , sudo systemctl disable systemd-resolved should do the trick.

I reinstalled and updated to the latest kernel a few days ago, now the Wifi is finally functioning well.
Just felt strange that this “bug” wasn’t caught by the developers, though I understand that the project is huge.

I upgraded from 16.04. It’s been three days since and my connection keeps conking out. Everything is updated. All my other machines are 16.04 and they are all working fine. It’s just this one with 17.04 that keeps acting up, almost constantly keeping me refreshing a browser page because I keep getting the error that I am not connected even though I am.

Anyway, I’ll try a fresh 17.04 complete install and see if that fixes it.

Did not work either on fresh 17.04 install. So I thought I’d try Debian 9. That didn’t work either. These new Debian updates seem to be having a problem with wifi connectivity.

I am reverting back to Ubuntu-Mate 16.04 for the meantime. Will update again.


No problem installing and connecting to the internet via wifi on 16.04 LTS.

I guess 17.04 can wait.