Ubuntu 22.04 issue between Flatpak and Caja

Testing Ubuntu 22.04 I could not yet find some libraries needed to install blending packages like Hugin or Luminance-hdr that I use for photo edition. But as both packages are available in Flatpak I installed them through this way to work with them until LTS release is launched.
I have noticed that there is a kind of "short circuit" between flatpak and Caja. In both programs I am only allowed to open files whenever files are located in the linux or in the home partitions. I have two internal hdds of 4 tb each (synchronyzed) dedicated only to save pictures mounted on the media folder. As the picture shows, media folder does not appear and if I make a right click on a file located in one of these two hdds nothing happens.neither I can see media folder clicking in "open file".
My intention is to report this, if this is not the way I appreciate you to tell me where to do it.
Thank you

Hello Pala

Regarding Flatpaks in general - are you aware of the Flatpak application called "Flatseal". This is a GUI for setting the permissions for Flatpack applications installed on your system. If you do not already use it I suggest you install it an then try adjusting the settings options to see if your problem can be solved that way. :slightly_smiling_face:

Thank you very much for the suggestion. I gonna try it. Nevertheless flatpak is only under testing purposes but I don't like this system.



I installed flat seal and it has permissions fields to enable the access to all system files. Nevertheless I couldn't see in this GUI the way to save settings because when I close it everything goes to default settings again. At least in U.M 22.04 there's no button reading "save settings" or sthg like that.
Will keep on trying...

Moreover... I run from a terminal as root

sudo su
flatpak run com.github.tchx84.Flatseal

In this case I gave both installed programs all permissions and when I exit application as root they remain authorized but when I open flatseal again permissions are given but from the program authorized itself I cannot open files in the partition where filesystem is, only the home partition is visible. Perhaps it works when you use only one partition for home and filesystem

In a second testing I opened programs from a terminal as root
sudo su
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=hugin --file-forwarding net.sourceforge.Hugin @@ %f @@

And only in this way I can see the entire filesystem