Ubuntu MATE 15.04 for Odroid C1

I'm creating this topic to gather useful resources to build Ubuntu Mate 15.04 images for the Odroid C1.
The available images will be published here.

I posted on Odroid forum here so you can see the other side:

The product was available on December 10, 2014 and is made by HardKernel:

They published an Lubuntu 14.04 LTS release and an Android release. They only support those two images.
Since MATE desktop is not available for 14.04, we can't simply build it on the Lubuntu.

So we proposed to build our one image and here we are.

Ubuntu minimal build:

Someone build a 14.10 from 14.04 minimal how-to:

Sources code and Uboot release:

Video driver github:

root filesystem:

Someone build MATE from sources:

HOWTO: Custom kernel and linux distro for ODROID-C:

Some examples from other OS:
Debian: http://lifecs.likai.org/2015/01/installing-debian-on-odroid-c1.html
Debian Mini GitHub: https://github.com/tomuta/debian-mini-odroid-c1
Archlinux : http://archlinuxarm.org/platforms/armv7/amlogic/odroid-c1
NetBSD: https://wiki.netbsd.org/ports/evbarm/odroid-c1/

EDIT (20150314): added debian and custom kernel ressources
EDIT (20150517) added the odroid forum link:
EDIT (20150518) added link to the video driver github



I have been quiet those time but I didn't forgot my goal here.
So I'm glad to write from an Odroid C1 running with ubuntu 14.10 and mate desktop.

I get there from the lubuntu 14.04 provided by HardKernel, then upgrated it to 14.10 and installing the Mate Desktop.
With: sudo apt-get install mate-desktop-environment-extras
It works very well. I removed LXDE packages and Openbox, but some were missed (leafpad for example).

The ubuntu-mate packages (ubuntu-mate-core ubuntu-mate-desktop) were not available so it is just the MATE Desktop on ubuntu.

I guess it can be fix by adding the PPA ?

My most important concern is that the display is wrong. I don't know why.
The panels are black, the indications are merely lisible, the wallpaper disappear 2s after I changed it.
The only readible theme is BlackMATE, the others are stripped...
It is a mess.

I took screenshot to show you:

Not bad ? It is the screenshots.

What I have is that (taken with my cellphone):

Anyone as an idea to fix that ? I don't even know how to characterize it.

I tried do reinstall xserver-xorg-video-mali (with a purge), but nothing change.

Hi Bakaniko.
I do have a C1 and im using the Official Ubuntu image.
On my Linux testing i’m always using the Linux mint distribution because of mate.

I’m going to do a try on this image on my C1 to see how it works.

One issue.

For a complete nooby how do i install this on my C1.

Is there any img or do i have to start from where.

Nice to meet and welcome on this Odroid C1 / Ubuntu MATE adventure.

For the moment, I wasn't able to provide a usable image so it was not published. The displa y is very bad on my screen (a driver issue I guess).

But you can make it one easily.

Save your current system or try it on an other SD card.
I started from a stock image, changed the sources.list (trusty to utopic).
After updating and upgrading it, I installed mate packages:

sudo apt-get install mate-desktop-environment-extras

I uninstalled LXDE and reinstalled lightdm (to be sure)

Here is my sources.list:

See UpgradeNotes - Community Help Wiki for how to upgrade to

newer versions of the distribution.

deb Index of /ubuntu-ports utopic main restricted
deb-src Index of /ubuntu-ports utopic main restricted

Major bug fix updates produced after the final release of the


deb Index of /ubuntu-ports utopic-updates main restricted
deb-src Index of /ubuntu-ports utopic-updates main restricted

Uncomment the following two lines to add software from the 'universe'


N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team. Also, please note that software in universe WILL NOT receive any

review or updates from the Ubuntu security team.

deb Index of /ubuntu-ports utopic universe
deb-src Index of /ubuntu-ports utopic universe
deb Index of /ubuntu-ports utopic-updates universe
deb-src Index of /ubuntu-ports utopic-updates universe

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also, please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

deb Index of /ubuntu-ports utopic-backports main restricted
deb-src Index of /ubuntu-ports utopic-backports main restricted

deb Index of /ubuntu-ports utopic-security main restricted
deb-src Index of /ubuntu-ports utopic-security main restricted
deb Index of /ubuntu-ports utopic-security universe
deb-src Index of /ubuntu-ports utopic-security universe
deb Index of /ubuntu-ports utopic-security multiverse
deb-src Index of /ubuntu-ports utopic-security multiverse

I tried to install Ubuntu MATE from the ppa maintened by @Wimpy:

I get this:

sudo apt-get install --no-install-recommends ubuntu-mate-core ubuntu-mate-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ubuntu-mate-core : Depends: mate-desktop-environment-core but it is not going to be installed
Depends: ubuntu-mate-default-settings but it is not going to be installed
ubuntu-mate-desktop : Depends: compiz but it is not going to be installed
Depends: mate-menu but it is not going to be installed
Depends: mozo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This week there is 7 failed build, all concern armf arch. So It is not ready for the moment to install on trusty.


you might want to try the PPA's from here:

Hi, didn't know/think about this one.
Tryed it but i got that:

The following packages have unmet dependencies:
mate-desktop-environment-core : Depends: mate-control-center (>= 1.8.0) but it is not installable
Depends: mate-panel (>= 1.8.0) but it is not installable
Depends: mate-polkit (>= 1.8.0) but it is not going to be installed
Depends: mate-menus (>= 1.8.0) but it is not installable
Depends: mate-terminal (>= 1.8.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

Sorry, my bad :sob: , I just noticed you want the PPA for Ubuntu Mate 14.10:


Don’t !
In fact I’m looking for a working way, with 14.04, 14.10 or even 15.04…
I’m just looking for a working image of ubuntu MATE, I just try several ways.

For the moment, my ideas went short, so every idea is welcome

Do you have your software sources download location set to “Main”?. :smiley:

@Bakaniko I’ll be releasing an Ubuntu MATE 15.04 generic armhf rootfs soon.

@wolfman I check it yesterday, and all entries are “Main” set. The I crashed the image trying to resolve a wifi issue.

@Wimpy Great news. How do you plan to do it ?

@Bakaniko It will be a tarball.


I started to play with the tarball yesterday.

I tried to chroot in the
folder extracted but i get this error “chroot: failed to run command
‘/bin/bash’: Exec format error” who seems to be a 32/64 bits issue.

I tell my self: if i use an official image from hardkernel, the
bootloader will be already in, and I can backup the /boot to get the
I have hard time to locate the mali 450 driver to stick it on the new folder…

It worked, partially. the system booted but sytemd can’t start the
journal service so i get stuck there and i was not able to access a
console. But at least the kernel was loaded so my idea was not so bad.

I posted the result on the odroid forum too:

Did I miss something ?
Where can I find the driver (mali drivers and xf86-video-mali ) for the mali 450 MP ?
If I can find drivers sources, how can I can access to th sdcard via chroot to complie them ?

The systemd error seems to be due to a read only fs (or file), is that from the copy (I used caja with sudo, the sudo cp didn’t worked) ?

Sounds like you’re making progress :slight_smile:You can only chroot from an armv7 device. Hope you’re able to get the assistance you need from the odroid hackers :slight_smile:

1 Like

Yes, this project move on, slowly but surely.
I had some advice from the odroid forumers so for now this is where I am:

Followed procedure:
Crating the base sytem by extracting the tarball (following the procedure given)
Installation of the latest img provided by hardkernel (ubuntu-14.04.2lts-lubuntu-odroid-c1-20150401.img at the moment)
Copy of pertinent folders and files from the SD card in the extracted rootfs:
• /boot #content kernel(s)
• /lib/modules #content modules needed by the kernel(s)
• /etc/asound.conf #sound card conf file
• /etc/fstab #conform to the initial partitionning so I kept it
• /etc/X11/xorg.conf # already set for the mali gpu

Wipe out the system partition of the SD card (without formatting)
/dev didn’t get removed totally (special files error) so I let it

Then I copy paste the modified rootfs in the system partition (I merged the /dev folders)

After that I just had to plug the SDcard and power the board.

Boot Sequence:
The system starts with a graphical environnement - O Joie ! -(the display is mostly black but mouse and keyboard are fonctionnals.

The setup started so I was able to change the language (french is very well translated), the keyboard layout, the timezone data, to create a user.
The installation went to the the creation of the installation logs, but after that a black screen with the cursor is displayed. Nothing more (no bars, no start menu…)
I restarted teh board (unplug/plug), and the installation part restarted again but most of the parameters were saved (language, keyboard layout, hostname…)

I tried to accès to tty2 but my login (with a simple password) or root can’t permit access.
So I’m stuck for the moment.

Issues (18/05/2015)
No tty access
Incomplet Display
Error message during boot about systemd journal (read-only ?)

To Do:
Unlock console
Unlock system (read/write rights)
Logs recuperation
Graphic driver installation

My savior ?


Loboris from the odroid forum make a custom script to creat ubuntu/debian imgs.
Ubuntu 14.04 of course but ubuntu 15.04 too.
It is possible to install MATE desktop with mali driver thereafter (and even KODI, wich I think is the best multimedia player for this for actually).
I will try it tonight. (Is it already Christmas ?)

1 Like

@Bakaniko This looks like something we could work with :slight_smile: I have an experiment…

1 Like

Great news it worked pretty well !
The scripts are well written and commented so even me was able to understand most of it.
I can't evaluate the code quality but the script are really neat.

I was able to make a first image, to boot on and then install mate on it:

It is really light at boot (but there isn't much installed for now).

And I had a surprise (I guess it will talk to you @Wimpy):

Do you see it ?

1 Like