Ubuntu MATE 16.04 laptop brightness not preserved

A possible work-around - did you check brightness options in your BIOS?

Stock Ubuntu or Xubuntu works fine. So I am sure it is mate-desktop related.

After reading this thread I don’t understand why we still don’t have a solution. I’m on MATE 16.10 with Intel graphics and have to adjust the backlight via panel applet after every boot and resumption from sleep.

@jawz101 that’s what I can’t seem to understand too. If this problem exists from 1.14 why has this not been fixed especially with common hardware like Intel graphics. Maybe there are workarounds for this but one shouldn’t have to go through all this trouble if the KDE, Gnome. Cinnamon etc don’t have this issue.

I think remember this bug from mate 1.8. It was fixed at 1.12.0.1 - which I checked on Linux Mint Rosa - but then I think something went wrong and that fix was lost. I think it does not get enough attention/complaint from users. I hope @Wimpy will fix it soon. They might be busy with gtk3 migration. At least now it is confirmed that this is a “problem”.
This is the issue I opened at github:


No attention there.

If I set the brightness by the command;
gsettings set org.mate.power-manager brightness-ac 60 it is preserved after restart.

@wolfman
I’m facing a similar issue as OP, but I don’t have cpufreqd installed. However, I do have cpufrequtils package installed. Do you think removing that package might help?

@prahladyeri can you confirm if the solution works? I am desperate to use Ubuntu Mate but can’t because of this bug

@Simon_Morgan What worked for me was something else. What I did was put the following two lines in the /etc/rc.local just before the exit 0 statement:

#Added by Prahlad:
echo 46 > /sys/class/backlight/intel_backlight/brightness

EDIT:

However, this solution may or may not work for everyone. The /sys/class/backlight/intel_backlight seems to be specific to some vendors, make sure the folder is available on your system before proceeding with this.

Great thanks. Do you mind explaining to me what this line does exactly for learning purposes. Also double checking, you said two lines but it is only one…

thanks so much

I am currently on Unity until a fix is found. I do see that my system also uses the intel_backlight files

Sure. All this code does is set the brightness to 46 level. This is a vendor-specific attribute so test this line using sudo beforehand to ensure that the brightness level is exactly what you want. On my laptop, 46 is the level at which the brightness seems optimal, on your device it could be something else, so set it accordingly.

And yes, its just one line of code. I had counted the comment I had placed as another line :slight_smile:.

Ah ok thanks makes sense. Does this mean though the brightness is fixed or just defaults at 46?

Hi all. Can anyone confirm is there is a proper fix or workaround for this by now. Issues

  1. default brightness on maximum
  2. Keypad light comes on with every reboot
  3. screen brightness setting not preserved

Lenovo Thinkpad T460s

I've been affected by a similar (maybe the same) issue for the past few days:

My laptop was booting normally, right up to the login screen, then I would enter my password and hit enter and the screen would go black.
Screen was actually set to minimal brightness and augmenting it via Function keys would correctly bring my desktop back.

I went to Control Center, power management earlier and noticed this:

Note: I was not on AC power at the time, so this setting should have had no effect. (Edit: and I don't remember ever touching that)

I moved that control to 100% and rebooted just now, and issue is now fixed, I don't have to use function keys after login now.

This was fixed after an upgrade in ubuntu mate 16.04 with default mate version. I then upgraded mate to 1.16 and it still works.

Unfortunately even with Mate 1.18 same problem persists for Thinkpad T460 laptop.

Did you try xfce4-power-manager and disable mate-power-manager from startup applications?

1 Like

No I havent but sounds like an idea worth trying. Thanks for that!

I noticed above that someone having this issue is running an xps13. Since my main development system is an xps13 the whole screen-brightness issue is important to me… the xps13 on full brightness in a dim room is an eye-melter, and i actually moved from debian-jessie to ubuntu-mate primarily to get the screen brightness issue to work.

It does work for me, though at times the keyboard backlighting is disabled (login screen) and must be manually reset if you can find that f-key in the dark. :wink:

It is absolutely essential, if you have an xps13, that when you do the install you permit the use of proprietary drivers. I’m not certain if the Intel 5500 graphics (i think that’s the one it has) needs proprietary drivers, but the broadcom devices definitely do (wifi and bluetooth as i recall). I started with a 16.04 iso file and the only unusual thing i did during install was permit proprietary drivers to be installed. Everything works pretty nicely, though come to think of it i haven’t had reason to try anything bluetooth with this install. I have no idea how to add proprietary drivers post-install but there’s a way to do it that i’ve forgotten (i forget everything that i can do without) since i ran into the same issue of needing proprietary drivers on another laptop, an ASUS T100 as i recall.

If it was me i’d back up all my user files and try a clean new install of 16.04 but i tend to keep things as simple as possible, so as to get something done before the 23rd century. :slight_smile:

I’m having this issue too. I switched to xfce4-power-manager, works fine now