Ubuntu Mate 16.04 LTS does not even boot live-dvd PowerMac G5

hi there,

was a Little disappointed - downloaded the latest iso and burned it to DVD (at 4x Speed, which is the slowest, I can choose from). DVD gets mounted, Looks good - but does not boot.

Oh and I burned on two different DVDs and also let DVD verify

Tried to hold “C” and DVD does not boot, tried “ALT”, no DVD Shows up, drives kicks out the DVD… hmmm

12.04.Ubuntu works, 15.04. Mate also. 16.04 Mate beta won´t, got some problem during boot, which I posted in another threat already.

I mean, come one - does nobody care about old PPC Macs anymore?
Does nobody test this, before putting it up to DL?
On what PPC machines do you test?
What PPC machines do “Mate PPC” target / actually WORK on?

If you got no mac, they´re pretty cheap - just raise some funds, I would gladly donate, so you guys can test on real Hardware…

Hi @Elowan,

start here as I don’t have one myself; I cannot really be of much help otherwise!:


I can’t speak for the MATE team, however, the problem with PPC is really out of their hands. The kernel will boot on my two iMacs and I can run live CD and install from there. It sounds like the kernel will not boot on your hardware. You might want to file a bug with Linus’ kernel team at https://bugzilla.kernel.org/

A couple of points…

What you describe sounds like a problem with your DVD, player or mac settings, rather than the ISO image. You should be using a USB stick anyway, rather than wasting the earths resources on burning multiple DVDs.

Does anybody care about PPC Macs anymore? Not really, or rather the numbers are getting fewer and fewer. Buying old PPC stuff is foolish (that was your first mistake), especially if you want to run linux and expect it to work problem free. But, linux is a great option if you have existing equipment. It is down to you to test the daily builds to ensure they work on your machine.

I can’t speak for 16.04, but a Mate compiz combo used to work well in 14.04 with 1.2ghz ibook.

hey Dave,

hmmm - that´s strange! 12.04, 15.10, 10.4 and even MorphOD are booting from live media…
Maybe, i have to burn another DVD…

Problem is, I have no other device (beside the PowerMac), that can burn a DVD - just a Toshiba Laptop, running Windows10.

But I think this will not work either, if I burn it on the Windows Laptop…

Maybe the devs should raise some Money or so, to get their hands on MacPPC Hardware to see, what´s going on?

A few weeks ago, I could have donated them some machines for free ^^

Or if they do really not care to make sure, their OS works on the claimed platforms - well - they should not say
:“PowerPC-based Macs and IBM-PPC: For Apple Macintosh G3, G4, and G5 computers, including iBooks and PowerBooks as well as older IBM OpenPower 7xx machines.”

I mean, come on… Mate on G3? are they serious? :wink:

hey veggrower,

booting PPC mac from USB is not that easy :wink: If this would work, I had done it already, instead of using a DVD.
I tried this on my ibook for about an hour or more and did not get it to boot from the USB stick - I think on the PM it will be the same.

I was thinking, there could be some “care about Mac”, because I think it is still the most of PPC´s out there, besides of some overpriced “Amiga-ish” Systems for 2-3k Dollars.

I do not think, buying some cheap PPC Mac stuff was a mistake - it was for nostalgic reasons and for fun.
I know a bit and have some other devices besides G5 PM and ibook: iPad, iPhone, Nexus7, Apple TV, Apple watch, a gaming PC rig with VR ready GTX 980ti, and so on… oh, forgot my two old iPod 1st gen P

The DVD-issue is not the Player, it´s very unlikely. Like I mentioned, 12.04. 15.10. worked form live, only 16.04 does not.
I installed OSX 10.4.11 from DVD, also worked.

I agree, Linux is a great Option and thank you for the hints !
I tested 15.10 on a 1.42Ghz MacMini (which I sold), it was way too slow and un-responsive.
So 14.04 would have been a better choice, I believe. maybe next time!


If your DVD is not showing up when you press the option/alt key on startup then it is failing to find a file with a tbxi attribute. Second troubleshooting question in the PowerPC FAQ describes how to get around this.

Oh and booting from a regular USB pendrive on an iBook is incredibly easy. If you have problems then 100% guaranteed you didn’t follow the advice in the FAQ.

Thanks for the heads-up !!!

I was following more than one tutorial, but “early” ibooks of the 1st G4 gen (800Mhz and 1.07 Ghz) are known to be not working, when try to trick Open Firmware - Believe me, I tried it myself - did you? :wink:

However, the 1.2Ghz and above models will work, that´s right - if you´re lucky and “boot ud:,\:tbxi” will work, yeah, this is easy. If not, well…

This is one of the tuts

I DL Mate via this torrent from this website - so maybe it is not a 64bit Client or something? This could explain, why the G5 not boot that DVD?

I checked, the Website says:“PowerPC-based Macs and IBM-PPC: For Apple Macintosh G3, G4, and G5 computers, including iBooks and PowerBooks as well as older IBM OpenPower 7xx machines.” - so it should work, I believe…

Kind regards

Hi @Elowan,

this is a bit old but might help?:


thanks, I´ll have a read

I burned DVD like explained here, using the “Disk Utility” Methode.

I looked around the net, but seems, there is no seperate 64bit .iso for ppc. There was no for 15.10 AFAIR (15.10 DVD boots!), so what is on my DVD should all be good, as far as I can tell!

I think I give up on this, because in the meantime I read about security-issues with 16.04 and there is still the bash exploit on ppc´s and so on. Guess 16.04 Linux is not that much better, than 10.5.8 OSX, regarding security.

If using TenFourFox on old osx, it should be not much of a difference to using Firefox on Mate - any other thoughts?

Like I said, 100% guaranteed. Lots of poor info out there regarding USB, and you’ve just added to it. As for your last post, I’m not sure what you’re going on about. I’ve already told you how to boot your DVD. Second troubleshooting question in the PowerPC FAQ.

You mean : https://wiki.ubuntu.com/PowerPCFAQ#The_CD_won.27t_boot ???

hmmm, let´s see_ this is because of a bug from 2012. now we have 2016 and 15.10 (so last year´s Version) runs without this bug… 12.04 dito (!) So this bug is back again with 16.04.? hmmm - seems strange

I will give this “boot cd:,\install\yaboot” a shot and fY!k around with open-Firmware again (for the last time, hopefully)

Was really hoping “PPC G3, G4, G5 Support” mean: Put DVD in, click a few times in installer, done!

I mean, I got Debian 8 running on ibook and it was pretty easy. just burn CD, boot with “C” key, Setup installer and boom-ready to use (except for WiFi and Sound, which I fixed after investing a few hours)

No. Linux on PowerPC requires you to get down and dirty with the kernel :slight_smile:

Ubuntu 16.04 is Debian 9 so I would expect Ubuntu based on Debian 8 to work.

The latest Linux on PowerPC checks the architecture and then boots a 32 bit or 64 bit kernel based on PowerPC model. It is likely that check is failing on your hardware for some reason. The developers do not have every model of Apple hardware to test. If you can figure out what’s wrong and report the problem – it will get fixed.

Hmm, that´s sad. So even if it´s a new Version, it will not work out of the box… but ok.
So it checks, if 32 or 64bit Version is needed, thanks for pointing that out.

In the meantime, I got the DVD booting (finally), “boot cd:,\install\yaboot” did the trick!

BUT - there is still a Problem: after a while you can see the ubuntu mate logo and the Progress bar (Points), then it Switches to a dark Screen again and states something like: “Noveau detected, switch to software… fbcon…”, then Screen get´s really funky (some weird colored Pixels - maybe a totally distorted Version of the logo), some small single Pixels all over the place.

After 2 minutes or so, the DVD stops Spinning. All I could do, was to shutdown the Mac…

Well - remember the time, when using a computer was fun?! :wink:

I ought to try MATE on my G3 just for torture/fun :grin:

Another Noveau/NVidia boot problem! Sigh!

Since you’ve used Debian before you might want to try the Mini install image at:

You should at least be able to get to a text based shell prompt.

I’m not sure that the GUI will work with your NVidia card since the patches that were put in place for the iMacs don’t seem to work for your hardware.

Sigh! I’ll be off the forum for a while so won’t be able to reply. Good luck.

1 Like

hey Dave, thanks for reply!

I got NVidia FX4500 Quattro 512MB PCIe Card in my PowerMac. I run Debian 8 on my ibook (ATI 9550) with lightDM and i3 window-manager, not on the PowerMac.

I remember, there are some boot-Options “ofonly” or something like that. Maybe I should try this?

What Advantages does the netinstaller have? Does it look exactly like the full ubuntu Mate Version, after install/Dl the components?
I remember installing a “MATE” Desktop from Debian 8 installer -but MATE does not look like “ubuntu Mate” from a “ubuntu Mate distro”…

I think, I will try this:

"For nVidia cards use the yaboot parameter nouveau.modeset=0 to disable KMS. This will disable both the nouveau xorg driver and the nouveaufb framebuffer (as KMS and nouveaufb are also inseparable) and you will fallback to the fbdev/offb driver. Note the openfirmware framebuffer has a limited colour depth - hence the ‘psychedelic’ colours you will see. You can increase the colour depth with fbdev by using a different framebuffer (such as nouveaufb or the legacy framebuffers nvidiafb or rivafb) and creating an xorg.conf that specifies fbdev, but if you can’t get KMS fully working then the better solution is to use the nv driver in your xorg.conf. "

I can’t if this work on a mac but on a PC I would use Gparted under tools create partition table then make your new partition then install ubuntu this always work for me

Yeah, I already have two extra partitions on my HDD - but I did not even get to the Point, where I could click on “install” :wink:

I tested the very same DVD on my ibook G4 1.33Ghz and it boots without having to fiddle with the Open Firmware and it also starts up the Desktop without graphics going crazy. So the Problems are just on the G5 Powermac, on ibook G4 it´s just fine…

I still need to test, if booting on G5 with “nouveau.modeset=0” will help…

Would be really cool, if there would be better Support for G5 PPC, because they are the fastest PPC Mac´s ever made and could still be put to a (limited) use.

1 Like