Ubuntu mate 16.04 wine install error

When I try to install wine I get this error. How can I install wine properly?

sudo apt install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:
wine : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Got anything weird going on in your sources?

inxi -r

Try installing wine1.6 and see what errors you get.

Also should you be using the 64bit package (wine1.6-amd64)?

You can try to fix broken packages.

sudo apt -f install

Hi @django,

see the update guide about correcting the “broken packages” problem:

Wine 1.6 from the official repositories could be considered old (but “stable”).

If none of the previous suggestions work, try installing the latest development build (1.9):

1 Like

My packages are not broken. Simply apt does not install wine, I think it is a dependency problem.

Dependency problems can be created by other ppa’s or a source fault, thats why I asked about your sources.

Are you sure you don’t have “Broken Packages”?. :confused:

To clear things out, I’m trying to install wine on a fresh install of Ubuntu MATE 16.04. I haven’t added any ppa’s to the system.
The same error happens on Ubuntu 16.04 with the Unity desktop.
Thanks in advance.

Ok out of lack of anything else to go on, I downloaded wine (wine1.6) all 164 packages/735MB.

It did install without error. Sorry but I don’t know what else to tell you.

What’s your architecture? 32-bit (i386) or 64-bit (amd64)?

Even if you think you don’t have “broken packages”, run the following commands anyway:

sudo dpkg --configure -a

followed by:

sudo apt-get update && sudo apt-get dist-upgrade -f

Restart if anything updates!. :smiley:

After fresh install + update, problem is solved.
Thank you all.

1 Like