Ubuntu MATE 18.04 missing microphone volume control in panel indicator

The level does change. Just tried to record some sound with Audacity and the audio is captured.

However a strange thing happens, if I connect a headset mic the indicator sound shows the mic volume control.

Try running alsamixer. There may be a setting there you need to fix.

1 Like
1 Like

Once again I thank you very much for your help.

I ran alsamixer and got a strange display which I do not remember seeing before, it was empty:

Only after I pressed F6 and changed the audio card I was able to get meters:

I do not know why it is identifying (I think) two sound cards, all I have is the sound device build inside the laptop.
After I chose the 'second sound card' I still do not have the mic volume control in the indicator sound applet.

Do you have suggestions on what I should try changing?

Use the left and right arrow keys to move to the Mic then the up arrow to set it on.

1 Like

The other device is your sound via HDMI output on the graphics card. Sorry I can’t help any further, but can clear that up for you. The HDMI doesn’t have input audio, so I wonder if this might be related.

1 Like

@MikeyBee thank you very much once again. I played around a bit with the bars using the up arrow and looking at the indicator sound but no luck.
Once again I tested to check if it was working and immediately as I connect an headset mic the mic volume control is displayed in the applet and it vanishes as soon as I unplug the headset.

This is my alsamixer printscreen:

@Martin_Booyzen thank you very much for the info.

What panel scheme are you using. In Mate Tweak, switch to another. See if the slider is there there. Then switch back.

1 Like

I'm using a modified Mutiny. I switched to several other panel layouts but unfortunately in none the slider appeared. I.e.:

Do you mean you are running the unity panel theme?

1 Like

Yes, the one called "Mutiny" in the available panel layouts:

1 Like

I may have given you the wrong instructions on alsamixer. After using the right arrow key to highlight Mic, try pressing the plus key to activate the microphone.

1 Like

It does the same effect as the up and down arrows, “+” and “-” just lower or raise the volume on the bars.

Sorry. That’s all I can think to do. Someone else in the community will have to help you now. If I think of anything else, I’ll post it. Good luck.

1 Like

One other thing I would try is to put in the other microphone and reboot. Then remove it.

1 Like

Thank you very much @MikeyBee for everything. I’ll keep on trying to solve this because it is something really useful to be able to control the volume of the mic at the distance of a click.

Maybe this is a bug, if no one will be able to figure this out I’ll file a bug report.

Try this:

apt list |grep -i pavucontrol

This will see if you have the pulseaudio volume control package.

1 Like

This is the output:

[code]$ apt list |grep -i pavucontrol

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

pavucontrol/bionic 3.0-4 amd64
pavucontrol-qt/bionic 0.3.0-3 amd64
pavucontrol-qt-l10n/bionic,bionic 0.12.0-4ubuntu1 all

That’s the same as mine.

1 Like

Where can I report this issue as a bug? Thought about mate-indicator-applet but then I saw this post, but here does not seem to be very appropriated, it does not seem to be MATE related.