Ubuntu-Mate 18-04 - some Java dependant programs crash - a solution


#1

Hallo

I use two Java dependant programs, Freeplane and ProjectLibre. Having updated to Ubuntu-Mate 18.04 I found that I could install Freeplane, but that it crashed when launched.

If a program crashes when being launched one of the best things to do is to start the program from the terminal, as you will then usually see the reason for the crash. Having launched Freeplane from the terminal a lot of comment was produced which included the following:

Exception in thread “main” java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper

A lot of internet searches later… I found this solution which worked for me:

(source: https://sourceforge.net/p/freeplane/bugs/2605/)

A)
Open a terminal (CTRL+ALT+T)

B)
Type:

cd /etc/java-11-openjdk

Note the space between “cd” and “/”.
Explanation: this moves you to the directory where the “java-11-openjdk” files are located.

C)
Type:

sudo pluma accessibility.properties

enter your sudo password when requested

Explanation: this opens the file “accessibility.properties” in the text editor “Pluma” with root (i.e. administrator) privileges.

D)
move down to the line which reads

“assistive_technologies=org.GNOME.Accessibility.AtkWrapper”

add a pound sign “#” at the front of the line to stop it being executed so that it reads thus:

“#assistive_technologies=org.GNOME.Accessibility.AtkWrapper”

E)
Save the file.

F)
Close Pluma.

After this I relaunched Freeplane successfully. I installed ProjectLibre after this and it launched without any difficulties; I cannot say if it would have launched without the above corrective action.

I hope this helps at least some of you to get your Java dependant programs running. :slight_smile:


Ubuntu-Mate 18.04 - ProjectLibre problems
Non-qwerty keyboard at login?
Am I the only one having a Really rough transition?
#2

Dear, @alpinejohn!

Thank you for your solution and efforts.

But we already have simpler solution on AskUbuntu with simple single-line commands:

  • for java-11-openjdk:

      sudo sed -i "s/^assistive_technologies=/#&/" /etc/java-11-openjdk/accessibility.properties
    
  • for java-8-openjdk:

      sudo sed -i "s/^assistive_technologies=/#&/" /etc/java-8-openjdk/accessibility.properties
    

Also we have bug 1788250 on LaunchPad - so developers are informed.


#3

Hallo

In fact the above fix (my previous post) did not solve all my java-related problems. There was still a problem with ProjectLibre and Java 11.

Neil James Devine kindly posted a fix on Sourceforge, :clap: where I had filed a bug report:

https://sourceforge.net/p/projectlibre/tickets/146/

The work around consists of installing oracle java 8 and setting it to be the default version of java.

Open a terminal (CTRL + Alt + T) and enter and run the following commands:

sudo add-apt-repository ppa:webupd8team/java

sudo apt install oracle-java8-installer

and then

sudo update-alternatives --config java

That is all you have to do.

In my case, ProjectLibre now works exactly as expected. :slight_smile: