Ubuntu MATE 20.04 LTS installation fails on new hardware

Hello everyone, I have a issue trying to install Ubuntu mate 20.04 on my newly built Ryzen 5, 3600. 20.04 will not install but 20.10 will is there a different with the drivers?

It also happens with Ubuntu 20.04 and 20.10 the 20.10 will install but 20.04 will not even boot to the live desktop

I'm just trying to figure out what's the problem

Thanks so much

1 Like

It likely has to do with 20.04 being shipped with kernel 5.4 and 20.10 with 5.8.
Your new hardware (CPU/GPU) might not be supported with the 5.4 kernel.
If 20.10 works, go with 20.10.

Thanks so much makes since, Is they anyway for me to create a USB with 20.04 and also use the 5.8 kernel and install the LTS versions?

Thank you


Hey @Robgoss, how u doing pal? Well i had this problem years ago when 18.04 came out. What i did was i installed 18.04 on my main disk drive in another computer, updated the kernel and then put it back into my newer setup. It worked for me. Hope it does for you in case you have a spare PC. Unfortunately one can't download a newer kernel version right off the rip when installing Ubuntu regardless of its variant. Tell me if it worked for you :+1:

Hello Caiodev, thanks so much

So I would have to install 20.04 and update the kernel for it correct? which kernel would I have to install in order for it to work? and then just install that ssd on this new machine.. I never updated any kernels before. I have plenty PC"s LOL
Thank you

1 Like

Well if you have spare PCs lying around you're already halfway there lol. Well, there's a great GUI tool to update kernel versions. It's called Ubuntu Mainline Kernel Installer

In this link you will find all the instructions needed to get it up and running.

I myself have been installing the latest kernel versions available for the last two years now(Except release candidate ones) without running into any kind of issues but if you want to keep it safe, install this application, go to Settings and check the "Hide unstable and RC releases" box and search for the 5.10.9 version on the main list. Install it and you should be good to go.

This application presents some weird behaviours sometimes such as telling you that a newer kernel version has been installed when it actually hasn't so, if that happens, just restart the application and try again. If you could, leave a star for the application author on GitHub to support their work.

If you have any questions or have any problems with the whole process, leave a comment here and I will try to reply as soon as I can :+1:

Thanks so much you have been a real help I will see what I can accomplish :slight_smile: have a great weekend

1 Like

Anytime pal. You too :+1:

1 Like