Ubuntu mate 24.04 not working for me

Hello All,
i was eager to try the new LTS release but unfortunately i cannot. I can install the OS from a flash drive and boot into the OS after the installation (with the flash drive removed). Everything works fine i can install apps, change settings and everything. the problem comes after the next reboot. I pass the bios then i got my error messages "No irq handler for vector" no big deal had those on 22.04 as well. but that is as far as i can get. Screen turns off after a while the monitor says not signal and goes to sleep mode. No key combination can get me to console only thing i can do is a HW restart but then i just get back to the black screen.

i tried reinstall the OS 3 times but always the same result.
so now I'm back to 22.04.4 no issues at all

if you have any thoughts what can be wrong let me know

my specs:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x
serial: UEFI: American Megatrends v: 3001
date: 12/04/2020
Info: 8-core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP cache:
L2: 4 MiB
Speed (MHz): avg: 3899 min/max: 2200/3900 cores: 1: 3900 2: 3900 3: 3899
4: 3903 5: 3899 6: 3899 7: 3899 8: 3901 9: 3898 10: 3900 11: 3903 12: 3897
13: 3898 14: 3899 15: 3900 16: 3899
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
v: kernel
Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu
resolution: 2560x1080~60Hz

you might need to upgrade your BIOS, this warning has to do with multiple cores of a cpu.
Also, check the XHCI mode in your BIOS.

I just installed um24.04 on a VM (allocated 4cores/8GB ram, diff env) but everything worked.


Welcome @jamesbolt to the community!

thanks all for hints.. will try the bios update and the settings..

1 Like