Ubuntu Mate on Macbook 2006 doesn't go to sleep

Hi! I’m new here and I need your help :slight_smile: so help me please :heart_eyes:
I’ve installed Ubuntu Mate 16.10 on my 2006 MacBook Black Intel Core Duo 32 bit.
The MacBook is reborn but I still have some problems; the worst is that the MacBook doesn’t standby.
If I close the lid the screen turn off but the apple on the back stay on as well as the fans.
I’ve searched the internet but I havn’t found an answer.
Thanks a lot and sorry for my bad english

Can you please provide the output of the following command in a terminal (Open with CTRL+ALT+T)

inxi -F

Here you are

System: Host: gianluca-MacBook Kernel: 4.8.0-41-generic i686 (32 bit)
Desktop: MATE 1.16.0 Distro: Ubuntu 16.10
Machine: System: Apple (portable) product: MacBook1 1 v: 1.0
Mobo: Apple model: Mac-F4208CC8 v: PVT
BIOS: Apple v: MB11.88Z.0061.B03.0610121324 date: 10/12/06
Battery BAT0: charge: 9.2 Wh 18.7% condition: 49.3/52.0 Wh (95%)
CPU: Dual core Intel T2500 (-MCP-) cache: 2048 KB
clock speeds: max: 2000 MHz 1: 1000 MHz 2: 1333 MHz
Graphics: Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Mesa DRI Intel 945GM x86/MMX/SSE2
GLX Version: 1.4 Mesa 12.0.6
Audio: Card Intel NM10/ICH7 Family High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.8.0-41-generic
Network: Card-1: Marvell 88E8053 PCI-E Gigabit Ethernet Controller
driver: sky2
IF: enp1s0 state: down mac: 00:16:cb:8f:ad:91
Card-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express)
driver: ath5k
IF: wls1 state: up mac: 00:16:cb:b8:d5:38
Drives: HDD Total Size: 410.1GB (1.9% used)
ID-1: /dev/sda model: Hitachi_HTS54322 size: 250.1GB
ID-2: /dev/sdb model: SAMSUNG_HM160JI size: 160.0GB
Partition: ID-1: / size: 227G used: 5.6G (3%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 2.11GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 26.7C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 195 Uptime: 3 min Memory: 701.6/1981.6MB
Client: Shell (bash) inxi: 2.3.1

another strange thing is that crt + alt + t doesn't open the terminal

You appear to have enough SWAP space to support suspend given the amount of RAM you have.
Have you checked the Power Management settings?

Right, it's a mac so maybe it's CMD+ALT+T or something like that.

Yes and all seems to be correct.
If I use OSX the sleep works.
I don’t know what to do because the sleep doesn’t work also niether if I click the button “suspend” on the menù…
Any ideas?
Thanks anyway