Ubuntu Mate only works when plugged in


I have an Acer and Ubuntu Mate only works when plugged in.

Any ideas why?

If I unplug it it freezes!

Thanks in advance,


Are able to start your Acer just on battery power?
Is this a dual boot machine? if so what’s the other OS?

Can you please test the following:

  • Trigger the freeze by unplugging it
  • Hit CTRL + ALT + F1

And tell us if you successfully switch to a text-based terminal.



Nope, just Ubuntu Mate…

The latest version.

It will start unplugged but freezes on Login prompt



Stayed frozen…


So it’s most likely a kernel issue. Did you do the driver & firmware packages install in Welcome -> Getting Started -> Drivers ?

Just downloaded the Install Firmware Drivers…

Is that the right one?

Please restart and see if you can reproduce.

Now it freezes before the login prompt.

Still the same as before.

Tried both options here too.

It also freezes on Shutdown.

Okay, please provide the output of:

inxi -MG

Also; what version of Ubuntu Mate and have you run all updates?:

OK - back!

System: Acer (portable)
product: Aspire E1-410
v: V2.05
Mobo: Acer
model: Aspire E1-410
v: V2.05
Bios: Insyde
v: V2.05
date: 03/11/2014
Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
Display Server: X.org 1.18.3
drivers: intel (unloaded: fbdev,vesa)
tty size: 170x48
Advanced Data: N/A out of X

Thank you ouroumov!

Hi Wolfman

I am on 16.04, the latest, at least I think so.

All updated.

Thank you!

1 Like

Hi ouroumov,

sorry to trouble you.

Just wondered if you have any solutions to offer or could suggest another distribution that might not encounter such an issue?

thank you.

Perhaps TLP, the power saver, is causing issues here? You can disable TLP by running the following in a terminal:

sudo systemctl disable tlp

Then reboot.



You nailed it!!

Thank you so much, made my morning.

Many thanks,