UM 17.04 WiFi working for you?

Well, it is not a broadcom device, it is a realtek wireless adapter. The sudo lshw -C net command says that it is using the r8712u driver but is unassociated with any network.

The lsusb command id’s it as an earlier Belkin device that can use the same driver as your N300.

Have you pulled out your ethernet cable yet and right clicked on the wireless icon? Does a wireless icon even display when you do that?

You should try some troubleshooting procedures (other than detaching the ethernet cable).

I've gone through the information you sent, and I think that maybe I've found something. I ran the command:

sudo lshw -C network

with the following results:

You'll notice that -network:0 (my wireless network) is DISABLED

I don't know if that means anything, but if it does, maybe I just need to enable my wireless network?

Right click on your network icon and make sure that Enable Wi-Fi is checkmarked.

Edit if that doesn’t turn it on, check your BIOS settings.

The Enable Wi-Fi is checkmarked

I checked my BIOS settings and didn't see anything related to Wi-Fi. I have a desktop computer which doesn't have built-in Wi-Fi, so I'm not quite sure what to look for or if there'll be anything in BIOS.

I did look in Control Center <> Administration <> Network and saw the following:

I don't know if this tells you anything useful or not.

When right-clicking the network icon, do you see any wi-fi networks listed? Does Edit Connections... display any former Wi-Fi network that you once connected to? You mentioned a 17.04 reinstall of some sort.

Here is an example. I used eth0 for some kind of install I guess a while ago and imelda is the main house wireless network.

Before reinstalling Mate 17.04, I was picking up three or four of my neighbor’s wi-fi signals, in addition to my own. I am now picking up nothing.

But this is something I tried, and it may be helpful. I rebooted into recovery mode and selected:

NetWork -------------- Enable Networking

This is what I got:

Trying to start NetworkManager…
Unknown group “power” in message bus configuration file

Could this have anything to do with it?

I think so. This may be a nameserver issue. See - Wifi issue in 17.04 post #11 for a fix referring to a reported bug. This may be a fix for you or maybe not. Edit: You oughta read through the entire thread just familiarize yourself with this issue.

Additionally, (and just in case it is useful) from - I got this helpful paragraph -

I found a solution about how to enable networking in recovery mode: get into root console, enter the following lines:

mount -o remount,rw /

dhclient enp3s0

echo "nameserver" | sudo tee /etc/resolv.conf > /dev/null

if you cant find out your ethernet interface’s name (enp3s0 above), try iwconfig (ifconfig is not installed by default) After these steps i was able to reinstall the package i deleted, using apt-get install.

I think that your wireless network interface name is wlx08863b9276e2 from post # 18 above but be sure to verify this. Good luck Jim.

By "root console" do you mean root in recovery mode, or as su in a terminal? I went to root in recovery mode, entered the commands as given, and after entering the last command was left with a blinking cursor. I didn't know what to do next. I tried exit, reboot, and finally had to do a Ctrl-Alt-Delete. I went back into recovery mode, selected enable networking, and got the same error message.

Either I didn't do this correctly, or it had no effect on my system.

LATER: It would seem that if the purpose of this is to change the address of my nameserver to, then I could do this through Control Center > Network. Going here I notice that the address of my DNS server is

and the address for localhost is and for jim-pc is

Could I not change the address here and then I think there's a command to restart the network manager? Here are the contents of /etc/hosts:

Is one of these addresses supposed to be

Nope. You are going down the wrong hole here. Control Center->Administration->Network will be of no help in your situation. Sorry. I think that my last post was way too scattered to do you much good - please ignore it.

Your problem is that your wireless network is disabled as shown by the results when you ran sudo lshw -C network. You need to find a way to enable this network.

Also, what you saw when booting into recovery mode, “Unknown group “power” in message bus configuration file” is probably not important in fixing your problem.

  1. Would you please show me what Edit Connections… displays on your system?

  2. Please boot into a live USB/CD session and see if your wireless network is recognized there.

Here's the result of Edit Connections.

Booting into live mode yields the same results.

I found this page on Network Connections:

With these instructions about wireless networks:

Here's the contents of my /etc/network/interfaces:

Hope some of this helps:

P.S. I'm embarrassed to mention this, but I have an Antergos iso on my computer. I burned the image to a USB and booted up. Both mine and my neighbor's wifi was recognized.

I’d follow the directions on the ubuntu help page. There must be a way to enable your wireless networking.

Do you know if this is a bug that might be addressed in some future update?

Possibly. See this - which was referred to in - Wifi issue in 17.04 where several people suggested fixes in mid-April.

It would be nice if one of those fixes applied to you.

I’ve got it working. I clicked on the Network icon in the top menu bar, and then Edit Connections. I then clicked on Add and selected Wi-Fi from the drop down menu. I had to enter my SSID, security type and password. I then clicked Save. I then went back to the Network icon and clicked Connect to hidden wifi network. My network was now available in the menu. I selected it and it’s now working.

It’s kinda strange that the network is not automatically being detected. Now that I’ve added my network, my neighbor’s network is being detected.

All of this is just way beyond my pay grade!!!

Glad to hear that you’ve gotten things under control Jim.

I appreciate your help. I’m glad it was something simple. I’m still getting the same error message when I go into recovery mode and click Enable Networking, so there’s still some issue there, but I can connect to my network. Thanks again, Jim