UM 17.04 WiFi working for you?

Continuing the discussion from Wifi issue in 17.04:

I’m curious if anyone who has tried ubuntu-mate 17.04 has been able to make a Ethernet or WiFi connection “out of the box” with out having to edit any configuration files first?

See the linked discussion if you like. I’m assuming most will be able to answer that they can, considering the lack of chatter about the topic.

So, what say you?

After fresh USB created from ISO, it did work initially.
I did the upgrade and then it didn’t work anymore.
From the very beginning the icon at the top of the screen was cold dead. Whichever way I was clicking on it.
I’ll try re-install the USB from the original ISO and see what it does.
I am not a ‘command line’ guy and the English computer jumbo-mombo is difficult for me to understand - since some written solutions seem to assume that there is no newbies around…

1 Like

FWIW, I’ve been using 17.04 since I upgraded from 16.10 just after the final beta, and my wifi is better than in 16.10. I used to get a ~30 second delay before it would reconnect after waking from sleep, while now it is essentially instant. Sorry yours is not is not working :confused:

1 Like

Just did a fresh install to test this out. Like elcste, I’ve been using 17.04 (sporadically) since the first beta and ethernet and wifi have worked flawlessly. Today’s install works flawlessly also. I just closed the lid for about a minute and the wifi conection was good.

However I use a firmware “upgrade” for my wifi driver, a broadcom (BCM4311) controller.

Edit: See -

It has been this way since 10.04. So “out of the box”, not quite.

1 Like

Thanks for the replies thus far. I believe your answers will be typical of most.

The computers I’m working with all have some age on them, which might in part explain what I encountered with this release. I only had to edit a couple files to make WiFi and Ethernet work properly, I’m happy with that. :slight_smile:

1 Like

As I was saying earlier, I just did reinstall the USB flashdrive with 17.04 from the ISO
Now the the wifi does connect… The icon on the top panel is useless though, not showing the connections available; while at least now showing that I<m connected to a wifi.

1 Like

Interesting, what exactly does it show you when you right click on it?

Left or right click does nothing. Related to the fact that I’m using the flashdrive on Surface 3 ?
Other icons do show a scroll down when clicking them though.

I have no experience with a Surface 3. Sounds like a interesting project though.

In fact I realized that the bluetooth icon and the keyboard icon are also completely dead. Clicking or hitting on them whichever way. Sound, battery and calendar are active as usual, though.
Bluetooth can be activated by going through the menu. I did same with the wifi.
I avoided calling for any ‘update’ this time around and wifi still works after a few dis/re-connection and shutdown sequences (although the icon doesn’t show any of this - except now I have the ‘wifi wave’ icon)
Intreging to say the least.
I’m traveling now and I’m curious to see what will happen when installing 17.04 on my desktop…
For now I won’t touch or tweak anything - providing it just does what I need fro the next few days.
Thanks for your interest, Steve.

Just want to chime in and say that the 17.04 kills my interest for Ubuntu and Linux temporarily. I used Ubuntu Mate since 16.04, worked great through 16.10 but I broke it when I tried to upgrade it to 17.04 beta. Never mind, I decided to install Xubuntu 16.10 on other partitions to try something new, which turns out not bad. Upgraded Xubuntu to 17.04, Wifi issues occurred, where Wifi is shown as connected but I cannot browse any site, cannot update/upgrade using "sudo apt update/upgrade ", etc.

I tried the followings:
(1) adding
[device] wifi.scan-rand-mac-address=no
to “/etc/NetworkManager/NetworkManager.conf”
No improvement.

(2) adding 8.8.8.8, most sites work but local sites (*.hk, even www.google.com.hk) may not work.

(3) using 4.11 AMD64 RC7 kernel.

The problem should be related to DNS because it’s fine when I pinged with IP addresses. I thought maybe the update from Xubuntu 16.10 to 17.04 caused the issue, so I fresh install Ubuntu Mate 17.04 (reformatted the original Ubuntu Mate 16.10). The Wifi issue still hit me in the face after this fresh install, driving me crazy. More than a week later, the problem is still here.

Until someone found a solution, I may stick with the evil Windows 10…

@Watford I hope you keep notes on what fixes you find in your quest to get Ubuntu Mate working on your Surface 3. That would make a great write up someday.

I determine that it was DNS related the same way as you did, by pinging a IP address.

If you have not already done so, you can see the step I took to get wifi working in 17.04 by following this link

https://ubuntu-mate.community/t/wifi-issue-in-17-04/12622/15?u=steven

There are two links in that post that may be helpful to you also.

The issues some of us are experiencing with WiFi in 17.04 are Ubuntu specific. All flavors are affected, not just Ubuntu Mate, as you saw when upgrading xubuntu 16.10 to 17.04.

What is there to do then?

I’m the kind of a person that likes to fix things. The part of computing that I most enjoy is installing and setting up operating systems. After I have one installed, tweaked to my liking, and everything is working well, all that is left to do is use it for everyday task, which honestly I find to be a bit boring.

I installed Ubuntu Mate 17.04 Beta 2 in hopes that there would be things that did not work so I would have a opportunity to fix them. However, I installed Beta 2 on a spare laptop. The laptop that I depend on is running Ubuntu Mate 16.04 LTS, and it will be until I upgrade it to Ubuntu Mate 18.04 LTS.

My point is that on any computer that one has to rely on, the best practice is to use the most stable version of your chosen operating system. In the case of Ubuntu that version is the LTS releases in my opinion.

So unless there is a specific reason you need to use a newer version, I would recommend you try a Ubuntu Mate 16.04 LTS live DVD or USB. Chances are it will work better for you than a newer version. If it works well with your hardware, then you can install it and have a stable operating system that has no need to be upgraded until the next LTS version is released.

Unless of course your are just using 17.04 as a learning opportunity as I am :slight_smile:

Some links you might enjoy

https://www.ubuntu.com/info/release-end-of-life

https://wiki.ubuntu.com/Releases?_ga=1.64771046.815780011.1492318950

https://wiki.ubuntu.com/UbuntuFlavors

I’m having the same problem. I use a Belkin USB wifi adapter. I recently reinstalled Ubuntu Mate 17.04. Before the reinstall the wifi worked fine. After the reinstall, I’m not detecting any wifi networks. My suspicion is that Mate is not detecting the adapter. I followed the directions at

and ran the command:

lspci -nn -d 14e4:

But it didn’t return anything! Zip! Nada!

I’ve moved the adapter to a couple of different ports with the same result. I’ve also tested the ports with another USB device and the ports are working. Any suggestions will be appreciated.

Jim

What does Software & Updates, Additional Drivers have to say?

OK. What does sudo lshw -C net display?

[email protected]:~$ sudo lshw -C net
[sudo] password for jim:
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: [email protected]:02:00.0
logical name: enp2s0
version: 06
serial: 74:d4:35:9d:fb:44
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:29 ioport:e000(size=256) memory:fe100000-fe100fff memory:c0000000-c0003fff
*-network:0
description: Wireless interface
physical id: 1
bus info: [email protected]:1.4
logical name: wlx08863b9276e2
serial: 08:86:3b:92:76:e2
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=r8712u multicast=yes wireless=unassociated
*-network:1
description: Ethernet interface
physical id: 2
logical name: enp0s19f2u1
serial: a6:07:fe:eb:f9:e9
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.200 link=yes multicast=yes
[email protected]:~$

Looks like you have a realtek wireless detected above. What makes you think that your Belkin USB wifi adapter has a broadcom chip? What is the model number of the Belkin device? Perhaps it is defective? Just guessing here…

Edit: What does lsusb say?

Belkin N300 Wireless USB adapter
Model: F9L1002v1

It could be defective. It was working before the reinstall. It would be a really weird coincidence if that's the problem. :confused: