Wifi issue in 17.04

i guess you are special. lol

I also tested the same live image on an old Thinkpad X61s with an Intel Wifi card and the result is the same - I wonder if this is actually a driver issue in the kernel? any ideas? anyone?

We’re of the same issue encountered.

My Internet works well after fresh OS installation. I just updated and upgraded my 16.04 LTS on RPi2. and no longer working after reboot.

Here’s my topic created:


yesterday, and my result was good. i don’t know if it could be distance from network.

In my case neither wifi nor cat5 LAN cable connects


Thanks a lot! This actually works! I managed to install the livecd this way. I will test to see if the changes are kept after a restart.
For others facing the same issue just do the following as per the bug report posted by django

> What I have to do is go and shutdown systemd-resolved (sudo service systemd-resolved stop) and edit /etc/resolv.conf to point to (my router) instead of

1 Like

The change in the resolv.conf file is reset at reboot so this needs to be done again; anyway hopefully Canonical will release a fix soon for this as they already acknowledged the bug and assign a high priority to it.

There needs to be a big

Wifi Warning 17.04

with the solution to fix it at the Download Page

sudo nano /etc/NetworkManager/NetworkManager.conf

and add this line to fix wifi issue


doesn’t work for me this one; the DNS solution is working.

I had the same network issues as @Jaime_Tayag when booting from a Ubuntu-Mate 17.04 Live USB.

From the live CD I also applied the same fix quoted above by @Blank. Followed by issuing sudo systemctl restart NetworkManager.service in the terminal to restart Network Manager.

At this point I could login, but could not connect to any URL.

To resolve this issue, I opened Network Connections from the Control Center, chose the wifi connection I had previously tried to log into, and click edit. Then selected the IPv4 Settings tab, and changed the Method to Automatic (DHCP) address only. Next in the DNS servers box I enter and clicked save. Followed by issuing sudo systemctl restart NetworkManager.service in the terminal to restart Network Manager. Wifi started working correctly after this.

This has to do with MAC Address Spoofing in NetworkManager 1.4.0


Also see Debian Bug report logs - #835822


Had to repeat all of the above fixes to the system once it was installed.

Along with editing /etc/systemd/resolved.conf and changing #DNS= to DNS= followed by rebooting to get the Ethernet wired connection working.

Booting from the live USB and system installation was all preformed on a late 2008 macbook. I have not verified if the same issues would be encountered on any of our other machines at the time of this posting.

Confirmed the same issue with wifi exist on a Dell 3542 laptop as shown in my previous post. In this instance login was possible with out applying a workaround, however I still had to point DNS to before wifi began working normally.

Edit: Confirmed on a HP 2000 laptop as well. Same results as the Dell 3542.

That is odd because for me it was the
sudo nano /etc/NetworkManager/NetworkManager.conf

I did this same step on another box I was upgrading and found that it worked just fine.

Probably because my router has a set dns server on it and forces all connections to use that server. (Maybe?)

Perhaps, must not be a common problem, or we would be seeing more of it in the forums.

I installed xubuntu 17.04 on another partition and had to go through all of the same steps for a fully functioning wifi connection, both from the live usb and after it was installed. Which only confirms what I have already read, this is a ubuntu 17.04 specific condition. However the results vary depending on hardware.

My WiFi 17.04 problem was that no WiFi was detected.
I did the BLank’s fix of adding wifi to NetworkManager,
then Stevens restart of NetworkManager, but it seems the “.service” at the end of his command wasn’t needed, I got a message about .service not being found, at the same time as the advise of wifi networks available.

I did this on the bootable usb drive, and either it carried it through to the installation or the updates fixed it.

On a Dell Dimension 9150 with a USB WiFi adapter, wifi doesn’t work. It’s fine on 16.10. The modem shows, but won’t connect.

I had to do the following before a connection could be made.

sudo nano /etc/NetworkManager/NetworkManager.conf

and add this line to fix wifi issue


Plus the other fixes listed above to resolve DNS issues

Did any of these help?

Thanks, but I don’t want to mess about, it doesn’t usually work anyway. I’ll wait until they release a fix and stay on 16.10.

I tried Ubuntu Gnome and Ubuntu Budgie and found the same problem, so I decided I would have to “mess about” after all. It didn’t work, but I found a similar suggestion on launchpad which suggested that it was also necessary to type:
sudo service network-manager restart

I tried that on an Ubuntu Budgie live CD and it worked, so I installed Budgie and repeated both the above, it still works! Budgie hasn’t got the missing window decoration problem I’ve had with Ubuntu MATE either, so I’m sticking with it.

check it working for me last time