UM 18.04 iPhone access to pix in their folders

Hi there

I just installed UM 18.04 and it runs smoothly. Love it.
There’s one issue. When I connect my iPhone with the laptop I can at times access the pictures on the device in their folders (what I want) and at times it forces me to use shotwell (what I do not want). How to I make sure I always have access to the picture folders?


I’m also interested by the answer to this question.
Though I don’t have an iPhone, I have noticed some inconsistencies when plugging in phones, be it iPhones, Android phones, and even Ubuntu Touch phones.

I had similar inconsistent results on UM16.04 and now UM18.04b2,
I’m using the “Traditional” desktop

I opened the “photos” on the iPhone firstly.
I plugged my iPhone 6S+ ((iOS 11.3) into the USB port.
The iPhone responded with a tone and the note “Do you trust this computer”
I do and entered my Phone password.
Meanwhile my screen on the UM18.04b2 displayed the Camera icon and the text “iphone”.Two windows also appeared on the UM18.04b2 desktop.
"Unable to mount Documents on “Name of iPhone” Unhandled lockdown error (-2)(I hadn’t Trusted the Computer yet)
and The "Choose Application " handler window. I selected the “Open folders” option.
It Worked!
I created new folders on my desktop for each of the Apple photo folders( Apple100 …etc.) .
I opened each Apple folder on the iPhone and “selected all” and dragged them to the respective folder .
I unmounted the iPhone and to confirm.
UM18.04b2 did not even recognize (nothing in the device window eith swo nothing to mount)the iPhone !!
Tried once more on a different USB port.
The desktop recognized the iPhone and TWO iPhone icons appeared. One showed the Camera icon and the other was something that looked like a cell phone with the text below "Document on xxxx iPhone A window opened and showed some random iPhone Apps. and the photo folders.
This is the last major issue I have before pulling the plug on Win7.
Another loosely elated issue appeared. I can’t rename folders on the desktop with the iPhone mounted. LOL
Sorry to be so wordy. NOOBI

1 Like

I agree. This is for me also one of the two last issues which prevent me from leaving windows completely. Anyone with a workaround to bring consistency into the matter?

FWIW, I had to manually start usbmuxd.service to restore access to the iphone device. :neutral_face: