Unable to Access Repository- Synaptic Package Manager

For the last few months whenever I try installing updates on version 22.04.3 LTS using Synaptic Package Manager I always encounter the same error message:


Taking a wild guess that your question is "How do I prevent the error message?" a quick search
gives this link.

I'm assuming your hardware IS NOT actually i386, but is something relatively recent using 64-bit.

The other error messages are self-explanatory, yes? You have to disable a security feature to use those external repositories. Whether you fully trust the repositories is up to you.

How to force acceptance without a release file is in the first screenful of the manpage referenced.

$ man apt-secure

Does that help?


Thank you charles-nix. Fixing the error message would be nice but being able to update my software would be even better. You are correct, I'm running 64 bit hardware. Since I now know that Synaptic Package Manager and Software Updater aren't trustworthy I might as well uninstall both of those GUI apps and use Terminal from now on to perform updates.

Where can I find a tutorial to learn the correct commands in Terminal to perform software updates and install packages?

Delete the offending repositories as in image then search for your apps and follow instructions for installation which will place correct repositories. Most are secure for mainstream apps as in image. AFIK Synaptic, Software Updater and Terminal Apt are using the same information.

will most likely show at end the offending problem the same as Synaptic.
Brave is used by lots of individuals with no issues. Etcher also but you can use Disks #6 in it's place.

Possibly you picked up some previous configuration settings.
A repository has multiple versions for different versions of the OS. Mine show jammy but they produce versions for other versions such as bionic and others. If the repository doesn't have a version for the OS you are at it will cause error shown.
Edit: no matter method you need internet to update.


Mendy, thank you for your help. I don't have a problem connecting to the internet. The error messages I receive from Synaptic Package Manager and Software Updater GUI applications say I do. I have too many more important responsibilities in my life that prevent me from spending hours deleting and reinstalling repositories.

If I could have used another browser to solve the problem without spending a lot of time trying to fix the repository issues that would have been nice but I get the same error messages in Google Chrome as well so the error messages aren't a browser issue.

Is there a tutorial I can use to learn how to perform updates and install software in Terminal? If not I might as well use the current version of Ubuntu until it crashes and install a newer version.

The terminal will give the same error messages. Here is Inkscape link and Brave link with some examples.



The Inkscape shows the Desktop method to add repository and the command line method.

The Brave shows the command line method.

Would suggest searching and reading up on Apt command to get better understanding of the command line method.

1 Like

You can go to this page:
Inkscape PPA Page

The previous post with Inkscape example sets the repository which points to this page (disregard the sudo commands at top).
Now when you check for updates the OS is pointed here and if you scroll down you will see it has a package for 22.04 and others. Thus if the repository doesn't have one for the proper OS version you will get error message. Also note this location shows packages of earlier versions of Inkscape. But when you type install for first time you will get the latest version and can't get the earlier one.
Edit: As earlier stated it will not matter which method you use to update as they all point for example here so if no package error message.

1 Like

There is nothing wrong with internet connection--that is only one of the possibilities why the repository isn't available. The real problem is found lower down. It is nothing to do with browser, but with settings for which repositories should be used. They're stored in text files at /etc/apt/sources.list, and under /etc/apt/sources.list.d/ BUT you can fully access them from Synaptic.

Synaptic, Apt, and apt-get are all the same software, loading .deb repositories, just with different interfaces. If one has a problem, all will have the same problem.

The Brave issue is that Brave no longer issues an i386 version. I can't say why your sources.list specifies one, but it doesn't matter. You don't need to reinstall all the software, you need corrections to your file that tells synaptic/apt where to find the software packages.

You can do everything about the Brave you need in a few seconds, within Synaptic, on the repositories lines. Just change to match what is on the link reference on the brave forum. Then reload repositories, then update. In Synaptic, choose Settings > Repositories. Then Other Software tab, and highlight the repository affecting Brave. Make the line look like the sample linked after the deb part -- meaning add the [arch=amd64] and that should be it. Or, you may have some reference locking into i386 in the same line that needs deleting. Close, reload repositories, update and you should be good.

The secure error is simply adding [Trusted=yes] between deb and http on the appropriate repository source line--also can be done right in Synaptic.

Or better, and not bypassing security, get the proper keys to the repository as a key file, and on the same page in Synaptic, two tabs to the right is the Authentication. Import the downloaded key file, and that's it. This issue was likely caused by manually entering a repository without importing a key file at the same time.

If the repository can't be troubled to provide a key file, I would be seriously questioning whether I need that repository, and whether it can be trusted, because it is trivial for them to do so.

Lastly, apt-secure is a basic component of Ubuntu. It is in the Apt package, which is required to have Synaptic running. I see the post was edited, so I suspect you figured out not to type the $ (or #) when someone offers a command to type? The $ or # is merely indicating whether you need to run the command as regular user or as superuser.

So there's no reason to go back to command line, nor expect to spend hours. All of us are busy, including people who take time to write answers on forums :slight_smile:


Balena Etcher .deb repository seems to be discontinued.

  1. Website promotes appimage for Linux systems.
  2. If you still want .deb, you can download one from Github.
  3. Upon inspecting latest .deb (namely, balena-etcher_1.18.11_amd64.deb), I see no repository address or corresponding gpg key in postinstall script.

So, @linuxis4me, your issues are of different origin. In case of Balena Etcher, for example, manipulations with your old Balena repository will not help.


I'm not complaining about all of the steps necessary to fix the repository issue and I do appreciate the time everyone has spent to help. Because of circumstances beyond my control I just don't have the time to go through an elaborate procedure at the present time. If I understand correctly, when I use the command 'sudo apt update' in Terminal it won't update my software because my current settings aren't allowing my computer to access the correct directory whether I use Synaptic, Software Updater or Terminal. I've never altered those settings since I installed Ubuntu on this laptop so I don't understand how they could have been changed to not let them access the appropriate repository. When I get some time I'll try your suggestions and see if I can resolve the problem. I'll check my other Ubuntu computers and see if any of them are experiencing the same issue.

Hi, @linuxis4me :slight_smile:

The switch in that apt list command should be --upgradable (two minus or hyphen signs followed by the word upgradable). Here's the output in my case:

$ apt list --upgradable
Listing... Done
gjs/jammy-updates 1.72.4-0ubuntu0.22.04.1 amd64 [upgradable from: 1.72.2-0ubuntu2]
libgjs0g/jammy-updates 1.72.4-0ubuntu0.22.04.1 amd64 [upgradable from: 1.72.2-0ubuntu2]

If you only use one hyphen sign or no hyphen signs before the word upgradable, you'll get wrong results as it happened to you.


$ apt list -upgradable
E: Command line option 'p' [from -upgradable] is not understood in combination with the other options.

Also wrong:

$ apt list upgradable
Listing... Done

I hope this helps :slight_smile:


Thank you for the corrections, ricmarques. I deleted that portion of my last post because I figured it was a mute point since Terminal can't access the appropriate repository anyway.


You didn't change anything. The repositories changed on their end. Brave dropped i386, Etcher no longer furnishes .deb , and maybe the other one changed their key.

To be clear, $ sudo apt update reloads the newest repository indexes. $ sudo apt upgrade downloads and installs the files. Both have to be run, and in that order.

The apt update is where you will have an error.

One important point: failing to load repositories only will affect brave, Etcher, and whatever the ppa is for. All other repositories will be updated, and all upgrades installed.


Thank you charles-nix for explaining what probably caused the problem and offering a solution. I checked both of my other Ubuntu laptops and they are updating without a problem. I'll try following your instructions when I have more time and see if it resolves the problem. I have a lot to learn about how repositories work.


I was busy for a few weeks and finally got around to trying your instructions. Unfortunately Synaptic won't let me edit the repository source links or add one. The add source button is grayed out so it won't function.

Follow the example given right above the APT line prompt box. You need four components:
"deb" (always either "deb" or "deb-src"
"version" (looks like "focal" in your case)
"repository" (for a PPA is probably "main")

The box is checking the completeness of your entry. When you enter an at least syntactically correct entry, you will be able to click Add Source.


I ended up unchecking the i386 box in the Synaptics repository sources and I was able to update to the latest version of Brave. Problem solved! Thanks to everyone for their helpful suggestions!