Unable to boot to external monitor when laptop lid closed

Hi All, I'm unable to boot into my external monitor with the login/secure desktop screen when my laptop lid is closed. Within my session the display settings look OK - laptop display disabled and external set to primary.

I've seen a couple of older posts referring to BIOS settings and /etc/lightdm/ but they dont seem to apply.

I'm running with an HP EliteBook Folio 1040 G3.

Any help is much appreciated.

See - https://askubuntu.com/questions/15520/how-can-i-tell-ubuntu-to-do-nothing-when-i-close-my-laptop-lid

I did the following:

Opened the /etc/systemd/logind.conf file in a text editor as root.

Added a line - HandleLidSwitch=ignore

Restarted the systemd daemon with this command:

sudo service systemd-logind restart

Closed the lid and rebooted to test if it works. Good luck @Martin_Coomber.

1 Like

Thank you for checking this out so quickly @mdooley. Unfortunately the issue remains and I need to lift my lid to locate the login screen after the restart.

Here are the logind.conf contents post reboot:

Any other ideas to try - difficult if you cant repro the issue (I'm newly from Windows so am carrying huge L plates in this environment)?

Perhaps also try this:

Open /etc/default/grub as root and do the following edits:

GRUB_CMDLINE_LINUX_DEFAULT="" omit quiet splash between the quotes
GRUB_CMDLINE_LINUX="text" add text here between the quotes


Uncomment to disable graphical terminal (grub-pc only)

uncomment by deleting # at beginning of line.

Reboot to test. As always, good luck on this.

Unfortunately the Grub update didn't work. After a bit of fumbling about I found Super(?) > Administration > Login Window (nice app). In here I went to Settings and updated Monitor to HDMI-1 from Auto.

Looking at previous similar but different posts I luckily guessed that /etc/lightdm/slick-greeter.conf stored this setting:


Any ways - thank you again for your help.

The two posts I provided were used on a laptop that automatically logs on with no appearance of a login window. I was reluctant to post simply because of that difference but did so anyway hoping to provide you with some form of help that might lead somewhere. Sorry that the above wasn't of that much help Martin.