Unable to Change Screen Resolution


Ran updates this morning for 18.04. Now screen resolution is set at 640x480 which is the only option in "Displays" that is available. I have Timeshift backups but can't get to the "Next" button at the bottom of the Timeshift window because it's off the bottom of the display and can not move the window up enough to click on "Next" button. Is this a monitor issue or CPU? Will a different monitor help at all?

OS - 18.04
Kernel - 5.4.0-42
Dell Monitor
NVIDIA GeForce GT 1030
CPU is AMD Ryzen 5 2600 X Socket AM4

Correction: Video card is GeForce GTX 1650

It's possible there is an issue with the nvidia driver. Do you remember if there was a kernel upgrade?

If you open a terminal and run nvidia-smi you should be able to see if the driver is working. While in the terminal please run uname -a and let us know what kernel and version is running.

I cannot give advice on using Timeshift. But for Windows that are larger than the screen you can hold down ALT and move the window with your mouse until you get the button visible.

You can try booting into an older kernel by pressing Esc to get the grub menu and choose an older kernel and see if that helps.

Good luck.

Regarding kernel, from what I remember of the list of updates, I don't believe there was a kernel update but I do remember "kernel header updates". Is there a command to run to see what the latest updates were?

Current kernel is 5.4.0-42 generic #46 ~ 18.04.01-Ubuntu SMP Fri Jul 10 07:21.24 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

When I run nvidia-smi I get "nvidia-smi has failed because it couldn't communicate with the driver. Make sure the latest driver is installed and running" So seems like the driver isn't running? Is that correct? Is there a "nvidia-smi start" command? Also ran nvidia-smi status and got same response.

Can you confirm the key to hold down when booting to get to grub is the "esc" key and not "shift key". I saw that posted earlier.

Holding down the "Alt" key allows me to move the Timeshift window so I can get to the next button. Thanks for that tip. Still new to Linux.


That is the latest kernel on 18.04 which was just released via the HWE.

That means there is an issue with the nvidia driver and the kernel. Sadly this kind of issue with nvidia drivers is not not rare.

The Esc is for accessing grub when using EFI boot. Shift is used with Legacy/BIOS boot. Based on the hardware you are using I anticipatedyou were using EFI. Try using one of them during the boot process and if that does not work try using the other after you restart.

We just saw another user who seemed to be having some issues with the newest 18.04 kernel. I'd urge you to file a bug on the kernel when you get back into the system.

Apt history is stored in var/log/apt/history.log you can view that by running pluma /var/log/apt/history.log

Before we dive down the rabbit hole that is nvidia drivers lets see if rolling back works and see if there is anything developed on bug reports for this.

How do I check to see if the Nvidia driver is running?

" Make sure the latest driver is installed and running"

It is not working as indicated by the output you posted.

Holding down either the "Esc" key or the left "Shift" key did not take me to a grub menu while booting the machine. I held the Esc key down the entire time while computer was booting up. Same for the Shift key. Neither worked. Are there more specifics to when I should start holding the key(s) down or is it more of a "tap (key) at specific time in the boot process?

I wanted to try this way first before using Timeshift to roll back to earlier kernel.


You find more details about Grub here: https://help.ubuntu.com/community/Grub2

You can also follow this from https://askubuntu.com/questions/16042/how-to-get-to-the-grub-menu-at-boot-time

For permanent change you'll need to edit your /etc/default/grub file -- place a "#" symbol at the start of line GRUB_HIDDEN_TIMEOUT=0.

ok, it's the right shift key.

So the top three in the list are
5.4.0-42-generic (recovery mode)

I thinking I need to select the 5.3.0-62-generic and reboot. Is there a way to make that the default kernel at boot?


Yes, booting into 5.3.0-62-generic did the trick. But going through the two sites you sent I didn't see how to make 5.3.0 the default kernel. Do I need to hit "e" for edit at the grub menu or edit the grub config directly? Or is there a better way to do it?


I see it now. Had to drill deeper.

Will submit bug report.


After updating the grub file here /etc/default/grubScreenshot at 2020-07-27 07-20-04

and running update-grub, it is still booting into the 5.4.0-42-generic kernel.

The steps under section 2. GRUB_DEFAULT= here https://help.ubuntu.com/community/Grub2/Setup#Configuring_GRUB_2 looks a little different than what I have. As example, I don't have GRUB_HIDDEN_TIMEOUTS.

Do I have this formatted correctly in the grub file: GRUB_DEFAULT=5.3.0-62-generic?