Unable to install software


my Ubuntu Mate 20.04 is not working properly on a raspberry pi 4. I use a german version, so the error message are in german. I try to translate them into english, but I am not sure, if they are correct.
When I run 'sudo apt-get update' I get the error message, that the destination is multiple configured in /etc/apt/sources.list:1 and /etc/apt/sources.list:4

Additionally there is a failure in fetching from http://de.archive.ubuntu.com/ubuntu/dists/focal/main/binary-arm64/Packages 404 Not Found [IP: 80]
Although I can ping the mentioned IP address

If I use the "Aktualisierungsverwaltung" which means adminstration of updates I get the message that downloading of software package sources failed and I should check the internet connenction, but WWW is working and also commands like ping are successful.

If I try to set the settings again, the operation system is trying to update the software cache, this procedure ends in a internal error of the program /usr/bin/blueman-tray or /usr/bin/software-properties-gtk. (I am trying to solve the issues for some hours, so receive the message several times).

Of course, I started the computer /raspberry pi 4) again.

If I try to install some software, for example 'sudo apt-get install openssh-server' I get the message that there is no 'installationcandidate'.

To summarize, I am despaired. The raspberry pi 4 is configured by my son. My mother in law should use it, but at the moment this is not possible.

For myself, I use on my personal computer debian "strech" release (9) without major problems. I bought in 1995 the linux book by Mr. Kofler (1st edition), so I think, that I am somehow familiar and I think I know to solve problems like 'plug the power supply into the mains socket'.

There might be one source of error. After booting I run the system form USB-HDD, not from sd card. So there might be problems to write file on the root file system, but I do not know how to check it.
But trouble shooting is very challenging, as there is no root user and always typing 'sudo ...' and typing the password again is not very user-friendly.

Is there anyone who can help me to solve these damn problems?

Best reagrds,

Welcome to the forum, @anhu. Thank you for asking this question, and I'm sorry to hear you've had difficulty updating the system / installing software.

To get to the bottom line: I really have no idea how the repositories got set to de.archive.ubuntu.com/ubuntu. They should be set to de.ports.ubuntu.com/ubuntu-ports, since ARM64 is considered by Ubuntu to be a "port" of Ubuntu and not necessarily a first-class citizen. :man_shrugging:

Anyways, the short answer is that you need to edit your /etc/apt/sources.list file to point to de.ports.ubuntu.com/ubuntu-ports. A quick command to do this automatically:

sudo sed -Ei 's de\.archive\.ubuntu\.com/ubuntu de\.ports\.ubuntu\.com/ubuntu-ports g' /etc/apt/sources.list

After you do that command, try sudo apt update again. Hopefully it'll work this time.

1 Like


sorry this does not work. In my opinion, there must be someone responsible for the repositories. May he/she help me? How to get in contact with?

Best regards,

Show us the contents of your /etc/apt/sources.list file, please. If you show me that I can probably help you myself.

Sorry, I try to post the content of the file but I get the error message:

Sorry, new users can only put 2 links in a post.

How can I post this? I tried


but both do not work!

Sorry for the delay, I walked away for a minute.

Sorry, I screwed up a teensy little bit. No, nothing's damaged; since you're in nano, (or you can use another text editor), replace the archive.ubuntu.com/ubuntu with ports.ubuntu.com/ubuntu-ports everywhere. Keep the de. part where applicable. And don't bother changing archive.canonical.com or any of those that say 'canonical' instead of 'ubuntu'.

That should work.

I'll bet the Aktualisierungsverwaltung (Update Manager, actually) is buggy and didn't detect you were running on ARM64, and thus added the conventional archive.ubuntu.com parts to your sources.list. That's my guess.

1 Like