Unable to Mount DVD

So I decided to upgrade to 22.04. Yes, I still write the installation image to a DVD. But today, for some reason I am unable to. I get an error message that the location is already mounted. My hardware configuration has not changed in a few years years. I first get these two error messages:

After clicking through I try to burn an image using Brasero and get this message:


Interestingly, Disks shows the DVD being mounted and Gparted does not.
Any trouble shooting suggestions to write the image to a DVD are appreciated.

Update: The problem is with 20.04 configuration. I booted to 18.04, no issue writing to DVD.

Have you tried a different DVD?

No, I don't have one.

HI think @mickee meant another disk not the drive.
Does work here in attached image. UM22.04.1 using Brasero.
Not addressing the cause of problem but found in past when I burn it works better at slower speed. Had issues at maximum speed.
Just tried two at 3X (never remember seeing that number) ended up with two coasters. Set to 4X and burned fine. Took 21min. 15sec.

I have the second one turned off but end result is the same. In Windows I think it was called auto insert notification. I stick a DVD / CD in I know what I want to do with it. Thing I miss once my HP printer quit there is no really good option in printers to print on DVD that are supported in Linux.

1 Like

Yeah, I tried several different disks including CDs. Same problem, interestingly, all works fine on same PC booted to 18.04. Brasero at 4x speed.

My Brasero is at 3.12.3. Doubt it but maybe remove and re-install it. Didn't really see issues, one was something to do with integrity checking only working with certain disks but didn't apply to burn.
Another thought are you using a single home partition for 18.04 and 22.04?
IE /home/user_name/.config/brasero Don't have dual boot to see if it keeps config separate.

I don't think the issue is with Brasero. I tried burning an image with Disk Image Writer as well getting the same results. I am thinking 20.04 now recognizes writable disks different (unsupportable now) than before for me. Some configuration change?

Don't know how you upgraded and other items.
Although you say same issue with Disk Image Writer you could try renaming the Brasero configuration at /home/user_name/.config/Brasero and relaunch to create a new one. Can always delete it and rename the renamed file back.

Another option is to try k3b another writer
Note: It does install alot of dependencies if that is a concern. I use ksnip and kmag and the extra dependencies don't bother me. Just personal choice.

Another possible thing to try would be to create the UM22.04 bootable disc in your 20.04 version. Then boot it / Try / Install Brasero and see if it works there. Used this method before I upgraded to verify that alarm clock applet would work in the new version, which it did. Overall I lost one very very seldom used app that can be handled with other app.

No it works in 22.04.1. I recently made an Ubuntu MATE DVD w/no issues. And I upgraded from a DVD created in 20.04 to the current version.

I have my work around, booting to 18.04. My work around also validates the DVD writer is still good. Now is the challenge to get it working in 20.04. I have used Brasero for the past two years in 20.04 until now. I am assuming an OS configuration change, but I will try a different writer and renaming Brasero.

Reinstalling Brasero did no good. However, I did notice if I change the iso file a few times, I am able to click on the burn button. Than I get this message:

I will try installing a different burner later.