"Unreliable CPU Thermal Sensoring Monitor Disabled" message at boot


#1

Receiving this message every time I boot. Something to do with the K10 Module.

Found the following potential fix:

On affected machines the module will report “unreliable CPU thermal sensor; monitoring disabled”. Users which to force it can:

Sudo rmmod k10temp
Sudo modprobe k10temp force=1

Confirm that the sensor is in fact valid and reliable. If it is, can edit

/etc/modprobe.d/k10temp.conf

and add:

options k10temp force=1

This will allow the module to load at boot.

                                             ---------------------------------

Tried:

  • sudo commands but no change…

  • Haven’t tried editing the config file… not exactly sure how to go about it.

Any insight or solution to this problem is greatly appreciated. Thanks.

CPU: AMD Phenom X4, 9150e Quad-Core
Ubuntu Mate 17.10


#2

Hi @LoRider,

have you made any changes in BIOS which may relate to the problem?. :smiley:


#3

Try upgrading to Bionic. That solved it for me, although I’m thinking of retiring the [expletives deleted] thing, anyway. I’ve never been able to get it to run right – even under Windows. Must be AMD’s Edsel…


#4

Hi Wolfman

No haven’t changed anything in the bios. Went into it yesterday and checked around for any thermal sensor entries but there were none.


#5

Hi LoRider,

you can try setting BIOS to optimal settings anyway for that just in case scenario!. I don’t know if it will help though?. :smiley:


#6

sudo nano /etc/modprobe.d/k10temp.conf

This will open a terminal-based text editor.

Write inside:

options k10temp force=1

Then CTRL+X, then hit Y (or whatever letter means “yes” in your locale), then hit Enter.


#7

Hi ouroumov

Your instructions on editing the k10 file were clear and concise and worked perfectly. Thanks for that solution and insight in to how it’s done.


#8

I'm trying to install Kali and getting the same error on boot after installing (Amd phenom 9750). After the error, screen turns off and no way to type anything. Any help?