Update caused USB WiFi to no longer work (22.04)

I updated my system recently via the command line (apt update, flatpak update, etc.). After rebooting, the system detects the USB WiFi dongle but does not connect to my router like it used to before updating.

The USB dongle uses RTL8812BU as the driver. Any idea what I should do to get connected again?

By the way, this happened while kernel 5.19.0-32-generic. Fortunately I also have 5.18.17-xanmod1 installed which runs okay. But I'd rather use the newer kernel. Any help would be appreciated. Thanks.

I have a rtl8812au and it seems to stop working every other kernel upgrade. It seems to be a Linux kernel problem with realtek, not an Ubuntu Mate problem. I have had the same problem on Mint also.
Short of booting into the old kernel I have not found a solution.

I was wondering if it's possible to rollback the updates I performed without being connected to the internet. Have you ever tried that?

No, and I wouldn't even if it is possible. Dependencies could be a problem. I put myself in dependency hell once, no desire to do it again. The best I have found is change the old kernel to 1st load on grub and wait for the new kernel. Just make sure you check the next kernel before deleting the old one you are using. I had once were I didn't do that and had two kernels that didn't support my WIFI and had already deleted the old kernel that worked.
I have also had the same problem with an integrated Broadcom WIFI card. I don't know why kernels stop supporting a certain card for a time, and then start again. I seems once the support was in the kernel it would stay there.

I just did an upgrade and it said there was no original module for r8812 and that it added one. I don't use realtek on this laptop, so don't know if this will solve your problem, but it might.

Reddit suggestion: reinstall wifi drivers. I tried it by connecting computer with cable to internet (as no wifi available). Only that step already fixed problem. It suggests that wifidriver is somehow blocked from working and any IP signal is enough for a "wake up" call.

1 Like

Welcome @gregblue to the community!

This is what I did and I am now able to go online running kernel 5.19.0-32-generic. I reinstalled the drivers by following the instructions here: Linux Driver for USB WiFi Adapters that are based on the RTL8812BU and RTL8822BU Chipsets - v5.13.1

Now I have another issue to solve that I suspect is also a kernel issue because it has been happening since my last update & upgrade. I was hoping that when I got my USB WiFi dongle working, the error I've been seeing on boot up would disappear. But that is not the case.

On to the next issue....

Thanks to everyone who posted a reply.

1 Like

with the error happens again.
No Wireless and (never noticed before) no working BlueTooth.

Connecting 1x with ethernet will fix this weird error.
After restart Wireless and BT works again.

1 Like