Updated nvidia-settings, now X won't start

Howdy. I updated my nvidia-settings configuration to fix the screen tearing issue when playing video games. But I must have messed something up, because now after I've rebooted, I can't log in.

The login screen shows up, but once I put in my password, the screen blanks, flickers, then after a few seconds comes back to the login screen.

I created another user to confirm it's not user settings. Same result.

If I purge the nvidia drivers and use nouveau, everything works fine. It's just not optimal for gaming.

Looking at /var/log/Xorg.0.log, it segfaults for some reason. The first four lines here repeat a bunch, then the segfault. Other than this, I don't have much to go on.

[ 93.105] (--) NVIDIA(GPU-0): DFP-0: disconnected
[ 93.105] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[ 93.105] (--) NVIDIA(GPU-0): DFP-0: 165.0 MHz maximum pixel clock
[ 93.105] (--) NVIDIA(GPU-0):
[ 93.337] (EE)
[ 93.337] (EE) Backtrace:
[ 93.338] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x13c) [0x55cb53be1aec]
[ 93.338] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fa922ef23c0]
[ 93.338] (EE) 2: ? (?+0x0) [0x0]
[ 93.338] (EE)
[ 93.338] (EE) Segmentation fault at address 0x0
[ 93.338] (EE)
Fatal server error:
[ 93.338] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 93.338] (EE)
[ 93.338] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 93.338] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 93.338] (EE)
[ 93.353] (EE) Server terminated with error (1). Closing log file.

I also think it's pretty dumb that it says to look at /var/log/Xorg.0.log, but this is /var/log/Xorg.0.log.

1 Like

Well, I downgraded to the nvidia-470 drivers and now it's working.
Don't know why it worked on 495 for a while and all of a sudden died... but I'm good for now.

1 Like

the same thing happened to me. I'm running a geforce gt 1030

O got exactly same issue today, yesterday everything work fine. I have Nvidia 495
xserver-xorg-video-nvidia-495/focal-updates,focal-security,now 495.46-0ubuntu0.20.04.1 amd64 [installed]

Package has security update 2022-01-04
Version: 495.46-0ubuntu0.20.04.1 2022-01-04 16:06:41 UTC

That's is exactly moment when Xserver started to crash

Server crash happens always when i start Steam VR.