Updated - Security, Lost work - Unable to unlock session after being unable to exit from screensaver

Screen locks fine when screensaver is activated. About 3 days after enabling this, the unlock window appears but won't accept any input from the keyboard. End up having to click Switch User then it takes me to the login screen and I can input the password there and it opens the previously locked session - everything that was open is still open. Any ideas on how to fix this?

This is still happening to me even after a fresh install of UM 22.04.1 from scratch

Ok this is a serious issue. Yesterday I was unable to exit from screensaver, would not accept text in password box, my usual way around this, clicking on Switch User, did not work. I was stuck in a loop, every time I switched user and entered my password, it would take me back to my session, system still locked in the screensaver. I had to reboot. I lost a project I was working on, that I now have to start all over. So right now I've disabled the lock screen when screensaver is active, which is a huge security issue, and disappointment for me. I filed a bug ( Bug #1992476 “Unlock screensaver window will not accept text - c...” : Bugs : Ubuntu MATE ) ? Is anyone else having this issue? If you are please mark the bug as affecting you.

Hello mickee

Let's begin by eliminating some easy things (as potential sources of the problem):

  1. Do you have more than one keyboard-layout "registered" on your machine e.g. US + Canada french?
  2. How is your keyboard connected to your machine, USB-cable, USB-wireless, other?
  3. If you are using an external USB-keyboard, is it connected via a USB-hub?
  4. How old is the keyboard?
  5. What is the make and model of the keyboard?

It is always a process of elimination. We presume that the majority of Ubuntu-Mate users do not have this problem, so we start by looking at your equipment to see if the problem could be associated with some particular aspect of your equipment. :slightly_smiling_face:

thanks @alpinejohn for your response. Here are my responses:

  1. No just one US layout
  2. It is connected wired USB
  3. It is connected via USB hub, but I have tried connecting direct to computer
  4. Keyboard is about 6 month old
  5. Its a HyperX Alloy Core RGB - Gaming Keyboard

note: I am able to type in the password window for about 3 days after either using the cahnge user once or after having a forced reboot, then it stops working and I have the problem above.

Hello mickee

I think no. 5 could be the problem.

I have used different Logitec keyboards over the years without problems. I'm currently using a "CHERRY KC 6000 Slim". I suggest you try a different keyboard, preferably a simple one. :slightly_smiling_face:

I will try that. I have a wireless keyboard mated to this computer (came with)

@alpinejohn thanks for your suggestion. I swapped out for a standard HP keyboard, issue appeared again after about 4 "unlocks" so its not the keyboard. Weird. I noticed that the HP keyboard was wireless and had batteries in it, so it was always connected, even though I had a USB one plugged it. Perhaps it was confusing the system as having two keyboards connected at the same time. So I removed the batteries from the HP wireless keyboard and will see if the problem continues. So now just the one keyboard is attached. Fingers crossed.

I tried with 2 different keyboards, and made sure a second keyboard was not connected and ended with the same problem. No choice but to reboot. Can't log in. Seems like a bug to me. So no one else has the same issue? What else could it be?

Keep in mind that most people don't leave their machines on for three straight days before rebooting. So no one else reporting this problem doesn't mean that it is not happening.

Unless I misunderstand what you are saying.

So no one else has the same issue?

Not me, and remember that my uptime varies from days to weeks at a time.

What else could it be?

It could be a hell of a lot of things :slight_smile:
Even a crashed/frozen screensaver.
(if you want to check that: enable the sysreq keysequences)

But first check if a powersetting is powersaving the USB port in use by the keyboard (and sometimes the USB port of the mouse)

Use 'powertop' to check the powerdown settings of the USB ports.

I don't know what to look for, I will post the output

PowerTOP 2.14     Overview   Idle stats   Frequency stats   Device stats   Tunables   WakeUp                   

Summary: 707.4 wakeups/second,  0.0 GPU ops/seconds, 0.0 VFS ops/sec and 29.2% CPU use

                Usage       Events/s    Category       Description
             29.6 ms/s     219.6        Process        [PID 58008] /snap/firefox/1943/usr/lib/firefox/firefox
              2.4 ms/s     146.6        Timer          tick_sched_timer
            165.1 ms/s       9.5        kWork          intel_atomic_commit_work
             17.8 ms/s      36.7        Process        [PID 1452] /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth
             20.9 ms/s      25.9        Process        [PID 58424] /snap/firefox/1943/usr/lib/firefox/firefox -
              2.2 ms/s      20.6        Process        [PID 3074] marco
            254.8 µs/s      20.7        kWork          ieee80211_iface_work
            143.4 µs/s      15.7        Process        [PID 14] [rcu_sched]
              1.4 ms/s      19.2        Interrupt      [6] tasklet(softirq)
              1.1 ms/s      17.1        Interrupt      [34] i915
              5.3 ms/s      12.8        Process        [PID 58953] mate-terminal
              1.4 ms/s      14.4        Interrupt      [0] HI_SOFTIRQ
              3.5 ms/s      10.5        Process        [PID 58281] /snap/firefox/1943/usr/lib/firefox/firefox -
             19.5 ms/s       3.5        Process        [PID 3120] /usr/lib/mate-indicator-applet/mate-indicator
            268.4 µs/s      11.4        kWork          engine_retire
             79.3 µs/s      10.1        kWork          kfree_rcu_work
              2.3 ms/s       8.7        Process        [PID 3715] conky -c /home/mickee/.conky/TeejeeTech/Proce
            174.9 µs/s       9.5        kWork          intel_atomic_cleanup_work
             43.0 µs/s       9.6        kWork          kfree_rcu_monitor
            596.6 µs/s       9.1        Timer          hrtimer_wakeup
            217.6 µs/s       7.4        kWork          __intel_wakeref_put_work
              4.0 ms/s       5.2        Process        [PID 3390] python3 /opt/extras.ubuntu.com/my-weather-ind
            246.0 µs/s       5.7        Process        [PID 4465] /usr/bin/boinc
            211.6 µs/s       6.1        Process        [PID 58448] /snap/firefox/1943/usr/lib/firefox/firefox -
             51.5 µs/s       4.8        kWork          psi_avgs_work

<ESC> Exit | <TAB> / <Shift + TAB> Navigate |                                                                  

Hope I'm not overloading you, but I don't know how to read this

PowerTOP 2.14 Overview Idle stats Frequency stats Device stats Tunables WakeUp
5.8 µs/s 0.00 Process [PID 58869] /snap/firefox/1943/usr/lib/firefox/firefox -contentproc -childID 11 -isForBrowser -prefsLen 35962 -prefMapSize 2285
5.0 µs/s 0.00 Process [PID 3115] /usr/bin/caja
2.9 µs/s 0.00 Process [PID 59230] /snap/boinctasks-js/33/boinctasks-js --type=utility --utility-sub-type=network.mojom.NetworkService --field-trial-h
2.7 µs/s 0.00 Process [PID 1764] /usr/libexec/rtkit-daemon
2.7 µs/s 0.00 kWork wireless_nlevent_process
2.3 µs/s 0.00 Timer neigh_timer_handler
2.2 µs/s 0.00 Process [PID 1566] /usr/sbin/kerneloops
2.2 µs/s 0.00 Timer writeout_period
2.1 µs/s 0.00 Process [PID 58879] /snap/firefox/1943/usr/lib/firefox/firefox -contentproc -childID 10 -isForBrowser -prefsLen 35962 -prefMapSize 2285
1.8 µs/s 0.00 Timer blk_rq_timed_out_timer
1.2 µs/s 0.00 Process [PID 27] [migration/2]
1.1 µs/s 0.00 Process [PID 15] [migration/0]
1.0 µs/s 0.00 Process [PID 28] [ksoftirqd/2]
0.9 µs/s 0.00 Timer commit_timeout
0.8 µs/s 0.00 Process [PID 21] [migration/1]
0.8 µs/s 0.00 Timer it_real_fn
0.8 µs/s 0.00 Process [PID 33] [migration/3]
0.5 µs/s 0.00 Timer dev_watchdog
0.4 µs/s 0.00 Interrupt [2] net tx(softirq)
0.3 µs/s 0.00 Timer tcp_write_timer
0.2 µs/s 0.00 kWork rfkill_global_led_trigger_worke
0.1 µs/s 0.00 Timer tcp_delack_timer
100.0% Device Display backlight
100.0% Device USB device: 2.4G Keyboard Mouse (MOSART Semi.)
100.0% Device USB device: usb-device-8087-0024
100.0% Device USB device: USB 3.0 Device (USB 3.0 Device)
100.0% Device USB device: xHCI Host Controller
100.0% Device USB device: HyperX Alloy Core RGB (Kingston)
100.0% Device USB device: USB 2.0 Hub [MTT]
100.0% Device USB device: My Book 1230 (Western Digital)
100.0% Device USB device: EHCI Host Controller
100.0% Device USB device: usb-device-8087-0024
100.0% Device USB device: EHCI Host Controller
100.0% Device USB device: Wireless Device (Chicony)
100.0% Device USB device: USB 2.0 Hub
100.0% Device USB device: SABRENT ( )
100.0% Device USB device: CoolTouch(TM) System (Advanced Silicon S.A)
100.0% Device USB device: My Book 25ED (Western Digital)
100.0% Device PCI Device: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3
100.0% Device PCI Device: Intel Corporation H61 Express Chipset LPC Controller

Exit | / <Shift + TAB> Navigate |

Wrong page :slight_smile:

Just go to the tab "tunables" and you will get a perfect overview where powersaving is applied.

'good' means 'powersaving'
'bad' meand 'no powesaving'
You want the USB entries 'bad'

It resets to default when rebooting so if it works for you you might want to make an entry in /etc/rc.local for it.

ok, so I Think they are set to good. How do I toggle them to bad?

You can use the cursorkeys to select the thing that you want to change.

And look at the bottom line of your uploaded picture:

<Enter> Toggle tunable

That means: if you press the [enter] key , you will change the value of the thing that you selected that you decided to change.

Shouldn't be too hard I think :wink:

b.t.w.: if you toggle a tunable, the commandline instruction that invokes it
is printed in the top left corner of the application.
( You can use that later in /etc/rc.local if you want to make the change permanent.)

thanks for the help @tkn

I disabled (bad) all USB devices, set the screensaver to lock when activated. We will see what happens

After toggling all USB devices to Bad - after 2 days the screensaver was unable to be unlocked. I can still click the buttons, but I can't type a message either on Leave Message or in the password box. Any further ideas? I'm open to trying anything (that won't break my system, lol)

Yes, it could be that the screensaver itself is the culprit.

This is the best thing you can do at the moment:
You could remote login from another computer and kill the screensaver from there and see if it solves the problem.

If, for whatever reason, you can't remote login, there is another way which is a bit more work:

I used to have a script to restart the screensaver upon crash or freeze when I was running UM 20.04
Since UM 22.04 I don't have any issues anymore (so I don't need it anymore).
Read this carefully (including the links):

1 Like

where is the log so I can see if this is a screensaver crash? Is that link to create a script to restart the screensaver? How do I create/save such a script?