Upgrade from 18.04 to 20.04. Install-info issues

First of all, I would like to thank everyone in the ubuntu and ubuntu-mate team for their hard work that has made possible this new release.

Regarding the issues I encountered during the upgrade process from 18.04 to 20.04, I have to say that the upgrade went OK and everything is working fine right now, but during the upgrade I got some errors regarding the "install-info", "info" and "ubuntu-standard" packages (apparently some dependecy problems and for that reason they were left unconfigured).

When the upgrade finished, I got a message where it said that errors were encountered during the upgrade process and the system might be unstable or unusable. I acknowledged the message and got the upgrade succesful message.
I rebooted my machine, and everything seemed to work correctly, but when I tried installing new packages I got errors from the packages I mentioned before and the install was aborted.

After some research I was able to solve this problem and right now the system is working fine. Apparently the problem was releated to the /etc/environment file:

-My original file had this lines:

-Modified file:

I still need to do some more testing and check what might not work after removing the line from the /etc/environment file, but for now everything is OK.

I would like to provide as much info. about this as possible, but I don't know how to get a report or which log might contain these errors (maybe syslog?), but if anyone could point me in the right direction I would gladly upload the report.


I'm not sure what added the JAVA_HOME line, but this line alone is just telling Java applications which version of Java to use.

You can find out which version is in use by running this in the :terminal: Terminal:

java -version

For example, I just have Java 8 OpenJDK that's recommended for a Java game, so my version is:

openjdk version "1.8.0_242"
OpenJDK Runtime Environment (build 1.8.0_242-b08)
OpenJDK 64-Bit Server VM (build 25.242-b08, mixed mode)

Thanks for your response.

The JAVA_HOME line was added by me. I installed Minecraft but couldn't play the game due to compatibility issues with the java version that was installed at that time on the computer, so I had to install Java 8 and change it to the default.

Right now if I run the command on the Terminal, a get this:

openjdk version "1.8.0_252"
OpenJDK Runtime Environment (build 1.8.0_0252-8u252-b09-1ubuntu-b09)
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)

Right now the game and everything else is working fine, eventhough I deleted the line I added previously to the environment file, so problem solved:)

Is good to know that this isn't a common issue, and that it occurred because of something I did before the upgrade. Still, I hope that this info is of help if by any chance anyone comes across the same problem I had.

:bulb: Since it's just an environment variable, a good practice would be to keep it contained within your home folder by adding it to either .bash_aliases - a hidden file in your home directory:

export JAVA_HOME="/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/""

(Create it if it doesn't exist)

This would be inherited by applications on the next login. It would prevent any future packages having to deal with conflicts when system-wide files were changed since it was installed.

1 Like