Upgraded from 16.04 to 17.10 and cannot log-in

I upgraded today from 16.04 to 17.10. The upgrade seemed to have gone well, completed with no problems, cleaned up and restarted my computer. At the log-in screen my name appears but I am not able to input my password. The mouse cursor is gone and there is no keyboard input. I tried changing the USB ports that I use to connect the mouse and keyboard with multiple mice and multiple keyboards and still nothing. Even after multiple reboots nothing. My keyboard does work when I am at the GRUB screen and I am able to select Ubuntu (I have a dual boot with Win7 on a separate drive). My mice and keyboard are generic Dell and Microsoft, nothing special or unusual there.

I don’t know the solution of your problem but upgrading from 16.04 to 17.10 doesn’t really make sense in my mind. Ubuntu MATE 17.10 will be supported until july 2018 which means 2 months. In my opinion you should better install 18.04. It has support until 2021 and in two months there will definitely be less bugs than in 17.10.

Yeah, that’s pretty weird to upgrade from 16.04 to 17.10, as from 16.04 you’re supposed to be able to upgrade only to 16.10 (then 16.10 → 17.04, then 17.04 → 17.10) or straight to18.04. And 16.10 & 17.04 are not supported anymore.

So, first question, how did you upgrade to 17.10 and why didn’t you chose 18.04? Did you replace the precise repos by the artful one and did a dist-upgrade manually? If so, your system might be in quite a messy state and it’s not sure it can be fixed.

Now, for your login issue, what happens if you switch to a TTY (ctrl + alt + F1 or F2), login in text interface then run the desktop with the following command?


When upgrading in the terminal from 16.04, 17.10 is the only option presented right now (18.04 will apparently come later). There is a bug that removes an xserver-xorg file, though, and from what I have read the solution to the no keyboard/mouse problem is to reinstall xserver-xorg after restarting the computer in recovery mode. So, from the grub menu, choose the latest kernel/recovery mode and choose:

Drop to Root Shell
at the cursor, type in (separately):

mount -o rw,remount /

sudo apt install xserver-xorg-input-all

sudo reboot

If all goes well your keyboard/mouse should work, but if not a reinstall of xserver-xorg may be necessary. The other option is to download the iso and boot into your system with a live version of 17.10 and chroot. There is a tutorial here under Update Failure:


As per my separate post, I’ve upgraded to 18.04 from 17.10 but can’t log-in
I get a black screen that alternate between the little cursor on the top left and the mouse arrow that appears for half a sec.
I am trying the Ctrl-alt-F1 and it indeed shows the TTY… for half a second. Can’t grab on it.

I was doing the upgrade as an experiment just to see how it would go. I had a little time to kill. Thanks all for your input. I will try some of your advice a little later on today when I get home from work.

Well, I could not get anything to work. Even tried jumping up to a clean install of 18.04. No joy there either. Finally went back to 16.04, clean install.