Upgraded to 17.04 - Chrome taking forever at "Resolving host..."

I just upgraded from 16.10 to 17.04, and it mostly seems to be working ok. But I’m having a weird issue pop up while using the Chrome browser that didn’t happen before the upgrade. Whenever I open a new tab with a new page, it sits for 10-15 seconds with a blank screen and the status bar saying “Resolving host…”. Eventually the page will load, and pages on that domain will load quickly for the rest of the session, but any time I need to load a new domain it sits saying “Resolving host…” for 10-15 seconds again.

So it appears to be some sort of DNS issue, but I can’t figure out what it is. After some googling I’ve tried things like clearing the DNS cache and using the Google Public DNS, but I keep getting the same issue. And I’m really perplexed about why the upgrade would start causing the problem. Does anyone know what I could do to fix the delay on DNS requests?

PS I’ve tried the dnsmasq-base fix here, but apt says it’s at the latest version.

I think you are having this issue. Here is a work around in this bug report;

1 Like

Thanks. I shut down systemd-resolved and edited /etc/resolv.conf, and now DNS lookups are going noticeably faster.

Thanks a million, this was driving me insane. Next time I pick a distribution it will be one without systemd