USB3 disk not found

Just installed new eMMC Chip (bigger) with 16.04. Before I used 15.10. My USB3 drive was used every day. The new version does not find the drive. I remember, that 15.10 started with teh same problem, bus on the sudden it was detected.
I tried 3 different drives, one 2.5Inch with USB-power, 2 3.5Inch with own powersupply. Attached to USB2 the drives are found. I found following info

$ dmesg
---- snip ----------
[ 14.256060] [c7] usbcore: registered new interface driver r8152
[ 14.465823] [c7] usb 6-1: reset SuperSpeed USB device number 2 using xhci-hcd
[ 14.476447] [c7] usb 6-1: Parent hub missing LPM exit latency info. Power management will be impacted.
[ 14.477322] [c7] xhci-hcd xHCI xhci_drop_endpoint called with disabled ep ddcf6480
[ 14.477338] [c7] xhci-hcd xHCI xhci_drop_endpoint called with disabled ep ddcf64ac
[ 14.477352] [c7] xhci-hcd xHCI xhci_drop_endpoint called with disabled ep ddcf64d8
[ 14.548048] [c7] r8152 6-1:1.0 eth0: v2.07.0 (2016/06/14)
[ 14.548062] [c7] r8152 6-1:1.0 eth0: This product is covered by one or more of the following patents:
US6,570,884, US6,115,776, and US6,327,625.

[ 14.560449] [c0] usbcore: registered new interface driver cdc_ether

USB3 chio must be ok as network is ok and with my HW-info it is attached to USB3. The last lines of dmesg ouitput above semm to confirm that. But what about the disk drive and the error info before the ehter lines?

BEsides: how do I supply system infos like above in the right way? Other forums have an option to include “code” lines.

Please excuse, but there are mor problems. I will post in separate topics.


Hi @hfb,

I don't have one so please take a look here first and maybe one of the other forum members can help you later?:

To use a code line, see the picture below!:

1 Like

Thanks, now I will use this info.

Some additional facts according to my real problem:

an USB3-Stick also is not recognized. But my new USB-SPDIF interfaces is recognized and tested ok. So it seems the ports are not disabled. Is it possible, that there is missing a udev-rule?
I will try to find out by comparing to my old (15.10) installation.



no differences in /etc/udev between current and 15.10 installation


I have looked at the suggested post and find much similar infos to what I detect. My HD as a ASMedia Chip, but now the post based on 10.10 Ubuntu and I have 16.04. Addtionally it is proved, that there exist working drivers with 15.10 MATE edition. So this thread doesn’t help me.

Remarkable ist the fact in the other thread and in my situation that teh drive works on an USB2-Port and the USB3-ports work with USB2-Storage.

The other 2 Disks are a Trekstore, but lsusb doesn’t list any chip manufacturer (I don’t think that they have their own one. The same holds to the 2,5" drive from Toshiba. No chip given. But form Toshiba perhaps they have their own one as dirct interface USB3 to hardware, not like the 4TB drive with a USB3-SATA bridge chip.

USB-ID for the 4TB drive is 174c:55AA


Hi @hfb,

try changing your software sources download location and running updates again, it might help if you have something missing on your system?:

Ubuntu Mate Update Guide

High wolfman,

I tried to change the update sources according to your screenshots. With me there is only the german server as alternate one and trying that, the searched packages could not be found there. Remember, that my OS is not running on some standard pc, but the Ordoid-XU4 hardware and the package sources for this type OS are restricted.
I posted my problem now to another forum which is based on that HW and where developers of the manufacturer and supplier of this special mate ubuntu are arround and try to help.
I hoped to get rid of an old problem in 15.10 with my update, but instead of no longer having the USB3-disk started everey 30 Min after boot for some seconds only now I can’t use it any more at that ports.
If you find out something, or need more details about my error, I would supply that and be thankful for your help - and also for help by other people of course

Hi @hfb,

did/could you click on "Herunterladen von" and change it to "Haupt-Server"?:

It was "Hauptserver. I changeed to Server Deutschland resulting in not all package info could be loaded. So I reverted to to Hauptserver. But now I always have the same Error message wenn trying to update the sources via Gui. apt-get update is ok.


Hi @hfb,

try changing the download location to a different server and updating again?.

You can also run the following commands in "Welcome > Software > Fixes" and see if that helps?:

Hallo wolfman,

unfortunately I am ill, so today an tomorrow there will be no activities. But the hint via “WELCOME” I did try with following result:

W:Target Packages (universe/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Packages (universe/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Translations (universe/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Translations (universe/i18n/Translation-de) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Translations (main/i18n/Translation-de) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Packages (restricted/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Packages (restricted/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Translations (restricted/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, W:Target Translations (restricted/i18n/Translation-de) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:15, E:Failed to fetch  404  Not Found [IP: 80], E:Failed to fetch  404  Not Found [IP: 80], E:Some index files failed to download. They have been ignored, or old ones used instead.

This is, what happens every time when I try to update the sources list via any GUI tool; not with apt-get update?

Will be back here on tuesday I hope

Hi @hfb,

you have several 404 errors in your list which I am sure you are aware of; is basically a dead link!.

Go here (Deutsch) and repair your sources list first!:

Get well soon. Gute besserung. :thermometer_face:

Hallo wolfman,

Can't stop myself in acting a littel bit upon my problem. I opened sources.list and found
Hm, posting does not work, as the entries are taken as links. Try with uploading the file

Should I remove all but the de. entries or better revert to the non german servers. Are the entries for Main server all ok?

Add Ifnfo:
At 1st I atteched the HD to the USB3 port (before and on boot it was at USB2-hub. Then tested with hdparm an the speed of >100MB/sec to me ment, it ran with USB3 speed.
Commented the line for the HD in my fstab, powered off the HD and then reboot.
The dmesg lines concerning xhci-EP disable still appear.
After 2 minutes i HD power on. lsusb showed the drive so I restored the fstab to former state and mounted. Test with hdparm gave a speed of >100MB/sec.
To me this is related to a boot problem and would think has to be covered by hardkernel, the HW supplier and maintainer of the needed modifcations/addons/bootinfos for the OS.

@wolfman: Still would be glad, to get the info about correcting my sources.list (s.a)

Hi @hfb,

take a look at picture 36 onwards and let me know how you get on (Ändern Sie Ihre Software & Updates Einstellungen (Software & Aktualisierungen).

There is no such choice besides the 2 I have writen of (Main, Server Deutschland)

Did you see this picture and click on “Andere”?:

I saw this picture, but without "Andere"

I tried myself something more. Commented in the sources.list all lines but the de.server lines for xenial and xenial-updates then issued apt-get update

To me it is strange that then the output has with different lines in between 3 times IGN6 .... main and some lines after the 404-error for the same source. This for basic repo and updates

When I remove the main repo in the 2 lines in sources.list this happens to the universe repo which now is the first in the 2 active entries.
I checked the files in /etc/sources.list.d, but the files there don't contain any lines identical to entries in the sources.list. I can't understand what is happening there.

I think of copying the sources.list from my 15.10 and change there hte entries to xenial.
I supply the content in the upload

What do you think of that?


you can do it that way but make sure you change each entry that says “wily” for “xenial”!. :smiley:

Thanks, hope it will help
Must do it later on. Need some rest in before.

Ok did so and apt-get update was run without errors. Then dist-upgrade offered a new kernel (still not 4.4). Additionally in before I had added the option “nofail” to my disk in /etc/fstab to ensure normal boot when the disk cannot be found on boot.

Reboot after the dist upgrade resulted in a mounted USB3 disk with superspeed while the disk was attached and powered on while booting. dmesg still showes the disable EP lines, nut only 2 sec later the disk is mounted. This holds to the 1st reboot, I hope it will last on.

I am not sure; was it the new kernel or is sufficient to give the mount -a during boot more time by supplying the “nofail”

If the actual behaviour will be continued in the future, I am satisfied. So I mark this as solved.
Thank you for your interest and, your time and your helpful hints.

1 Like

Happy New Year @hfb, I’m glad it is resolved!. :smiley: