User background in Slick?

From what I understand, Ubuntu MATE switched to Slick but still uses LightDM (?). Is Slick just a greeter or a different login manager that somehow uses LightDM’s configuration?

Anyway, I can’t make it display the users background despite the option checked in the preferences (and the slick-greeter.conf having draw-user-backgrounds set to true). Not sure if this is the same issue that was already present in UM with LightDM or a new one but my old solution (the script that I made) doesn’t seem to work anymore.

Yes, AIUI, it is a greeter for LightDM, based on the one that was used for Unity.

Ok. So that’s weird that it doesn’t work for user backgrounds if it did previously. Unless it has its own way to handle them? Any idea?

I don’t unfortunately…

There’s something I don’t understand, maybe someone can help: where does Ubuntu MATE set the options for the default Slick greeter appearance? I’ve checked everything in /etc/lightdm, /usr/share/lightdm and /usr/share/slick-greeter and haven’t found any config file with the background used (/usr/share/backgrounds/ubuntu-mate-common/Green-Wall-Logo.png).

I’ve tried to tweak the picture and it was reflected in the login screen, which confirms that it uses this file and not a copy from somewhere else, so it has to be referenced in a config file used by LightDM/Slick but I can’t figure which one.

EDIT: just found it in another thread: it’s stored in dconf (

Ok, it looks like I’ve found the origin of the problem by checking if/how it works in Xubuntu (it does). The issue seems to be similar to the one UM had with LightDM before, namely a value for AccountsService that is not set by the settings daemon, except that it’s a different key used this time: Slick (or LightDM since an update?) apparently checks for the org.freedesktop.DisplayManager.AccountsService → BackgroundFile value.

If the user background is set as follows in /var/lib/AccountsService/users/$USER (where $USER is your username), it works for draw-user-backgrounds:


xxx being the path to the background image. For some reason, the path has to be put between quotes, even if there are no special chars in it.

I’ll look into it more thoroughly to fix my old script and automate this.

EDIT: script updated: LightDM doesn't show the user background