Verbose Boot for PPC

system

#1

Spent about an hour looking for the Grub file so I could get my PPC to show verbose boot up. Then, all of a sudden, the light bulb went off. Yaboot not grub on PPC. D’oh!

Is there a way to enable verbose boot on PPC?


#2

In your /etc/yaboot.conf file, the append statement is where you can control verbosity. I use “loglevel=4”.

image=/boot/vmlinux
label=Linux
read-only
initrd=/boot/initrd.img
append=" nouveau.tv_disable=1 net.ifnames=0 biosdevname=0 loglevel=4"

Make changes in “/etc/yaboot.conf”, and then run “ybin” to save changes.


#3

My yaboot.conf looks like this:

image=/boot/vmlinux
label=Linux
read-only
initrd=/boot/initrd.img
append=“quiet splash radeon.modeset=1 video=offb:off video=radeonfb:off video=1280x854-32 radeon.agpmode=-1”

A little different than yours. Any idea? Thanks.


#4

The option “quiet” disables all boot messages. You probably don’t want the splash screen either.


#5

If I remember correctly, when I installed, I had to enter that at boot up to be able to see anything. I’m kind of worried that if I change it, stuff’s not gonna work right at all. So, I’m not sure what to do from here. I guess it’s not a huge deal but, it would be nice to see what’s going on at boot up.