VGACON disables amdgpu kernel modesetting AmdGpu_init

mate 18.04 32-bit and 20.04 64-bit.

32-bit loads to black screen after mate startup logo, 64-bit (20.04) is using radeon LLVM without problems.

GPU is AMD RX 550.

Tried in grub "quiet splash nomodeset"
Tried in grub "quiet splash modeset"
Tried in grub "quiet splash amdgpu.dc=0"

IN 32-bit(18.04), all i can get to is black screen with cursor. I have oibaf ppa loaded and updated. I have taken out nomodeset, modeset, and amdgpu.dc=0 from grub and ran with just quiet splash. I always get this error.

20.04 64-bit I have changed nothing, compared both from grub and grub 2 under normal settings. If both have just "quiet splash" only 18.04 32-bit comes up with black screen. The display cycles (blinks 3 times (cycles) blinks 3 times, over and over. Other posts I have found have said running with no "quiet splash" or adding "quiet splash radeon.dpm=0" might work?

#lspci -k | grep amdgpu shows:
kernel modules:amdgpu

-so i apt update and apt upgrade, make sure ppa:oibaf is listed....

#lspci -k | grep amdgpu shows:
08:0:00 controller: Advanced Micro Development leka Pro (RD 550/550x) (RevC7)
subsystem:Gigabyte Tech Ltd. Lexa Pro (Radeon RX550)
kernel modules:amdgpu

Check grub, leave as "quiet splash", update-grub reboot....Still will not work....
Edit grub to "quiet splash nomodeset" update-grub, reboot
"quiet splash modeset" update-grub, reboot
"quiet splash amdgpu.dc=0" reboot
no changes......nothing changes

#lshw -c video shows :
description: VGA compatible controller
product: Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:08:00.0
version: c7
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=amdgpu latency=0
resources: irq:35 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:1000(size=256) memory:f0f00000-f0f3ffff memory:c0000-dffff

It SEES the card but will not work with it...

1 Like

I have the same identical issue here. Running Mate 20.04 to the latest kernel 5.13.8 . Set permanently nomodeset to get the HP ProDesk 405 G4 Ryzen 3 Vega 8 work on HDMI/DP connected Philips 42PFL3507H. Had many black screen issues installing Debian LMDE 4 and latest Mint Cinnamon that I solved in Mate adding permanently nomodeset in Grub. Now have generic unclaimed display and no sound coming from tv via HDMI even though I had it both work before Update and upgrade. Also no sound connecting headset to jack on pc .
Tried to install amd drivers from Terminal and via website and doesnt seem to fix it.
~$ sudo lshw -c video
[sudo] password for alan:
*-display UNCLAIMED
description: VGA compatible controller
product: Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:0a:00.0
version: d5
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: latency=0
resources: memory:a0000000-afffffff memory:b0000000-b01fffff ioport:2000(size=256) memory:b0600000-b067ffff memory:c0000-dffff

Setting back to splash screen modeset will return with black screen at boot. Same for amdgpu.dc=0
Pulsaudio Volume Control sees Raven/Raven2/Fenghuang HDMI/DP Audio Controller Off and disabled with no option to turn it on. Same with native volume control.

~$ lspci -k | grep amdgpu
Kernel modules: amdgpu

Same issue happened today with me, completely out of thin air. I'm using KDE Neon 5.22, kernel version 5.11, Ubuntu 20.04. I was launching some game under Windows (installed on a separate drive), when suddenly drivers broke. Booted up to linux - black screens, and no progress since then. Basically what I ended up doing is this:

  1. then got an error exactly the same as the title of this:
  2. Fb0: switching to amdgpudrmfb from EFI VGA - #4 by Terces - Linux - Level1Techs Forums
    Started seeing VGACON error message when booting after second step here.

EDIT: Also, sudo lshw -c video shows no driver in configuration line for me

Just followed Herbert Quain's answer and got all back on after reboot. Tv is detected and sound is also back on
I only note down the fact that I had done a full reinstall (nothing worked still though) yesterday and now I am running with 5.8.0-43-generic.
Also after command
sudo add-apt-repository ppa:oibaf/graphics-drivers

I did only update, not upgrade.

The scaling and desktop icons were however much better before, very Gnome 2-like. Now is all kind of small.

On second boot I am on black screen again.
Back to nomodeset.

This thing is getting ridiculous.
Is it possible that the issue is still unsolved?