Vice Emulator Will Not Run Solved

When I run the Vice Emulator X64 it says it cannot find the Kernal.
I try to check PATH but can not seem to locate it any where.
I tried bashrc but no luck.
Vice was installed in /usr/lib/vice/C64 for x64.


Just tried (in VirtualBox) and it’s running fine.

Here’s a How-to:

  • In your home directory, create a .vice folder, inside create a C64 folder
  • Download the Windows version of Vice
  • From the Widows version, copy into .vice/C64 three files, basic, chargen, and kernel
  • Logout (or restart) your system

You should now be able to have a trip down memory lane with the C64 emulator, have fun!. :smiley:


At first I got a lot of errors by typing x64. When I ran it from Applications, it did not give any errors.
Now I need to find out about the 128, plus4, etc.


Seem to remember trying the C128 and Vic, but that’s as far as I went. Same principle though, just make extra folders inside home .vice folder (/.vice/C128 for example), copying relevant files from the Windows Vice download.

Thanks again, I copied the other folders and it seem to be working.

You’re welcome! :slight_smile: :tv::joystick:

I had to copy kernalch and chargch from the web and it worked.
edit: for the 128.