Virtual Box and Mac OS Mavericks getting Full Screen and getting Access to host drives

I'm running Mac OS Mavericks under Virtual Box 6.0 and can't get it to run full screen or get access to my other files and folders. All the tutorials on Youtube are for Windows and show typing commands in command prompt so this does not work for Linux. Also I can't get access to my systems files folders even after I try adding a folder via the Shared Folders option but after that I can't find that folder anywhere in finder or when I click on the Macintosh Hard Drive Icon.
There is no setting under Displays in the Virtual Box setting for screen resolution, just how much video memory to assign the the Virtual Machine. This is in version 6.0 that I manually install from the Virtualbox.org Website because the previous version of Virtual Box won't even run Mavericks.

Thanks

It sounds like you have not installed guest additions nor even, perhaps, VirtualBox extension pack.


How to install guest additions:

  1. Start your VM in windowed mode

  2. On the virtual box menu, click on “devices/insert guest additions CD”

  3. Your guest OS should show it in its file manager and should even bring up the correct file to execute. Execute it.

  4. Log out and back in to the VM


How to install Virtualbox extension pack

  1. on the Virtualbox main window, click on “help/virtualbox website”. Then navigate to the extension pack link. However, if you wish, you can just click on the link below to get it. The download will ask you if you want to run it, after the download has completed, in VirtualBox. You should answer yes.

https://download.virtualbox.org/virtualbox/6.0.10/Oracle_VM_VirtualBox_Extension_Pack-6.0.10.vbox-extpack

  1. after the download has completed and Virtualbox has installed it. You are done.

If you do both of the above, you should find your resolution works correctly and your shared folders work

:point_up: I have heard newer versions of VirtualBox now supports macOS as a guest OS, so be sure to install the guest additions as @stevecook172001 suggests.

Have you got an example of the commands? It should be translatable to the Linux equivalent, for example:

VBoxManage.exe modifyvm "Your VM Name" --cpuidset xxxxxxx

Can be executed in the :terminal: Terminal as:

VBoxManage modifyvm "Your VM Name" --cpuidset xxxxxxx

Note that the command is case-sensitive, so vboxmanage would not work.

I did this I installed the Virtualbox extension pack and when I selected insert guest additions CD it put a VBox_GAs_6.0.10 DVD Icon on the Desktop so I clicked that and clicked on VBoxDarwinAdditions.pkg it went through the install processes and said it installed successfully I selected Shutdown powered off the Virtual Machine and then relaunched it and it still does not work, I still can't access the folders I set in shared folders or change the screen resolution to fill the entire screen,
right now it only fills the center of the screen and has black bars on the sides.
Also Seamless Mode does not work, hitting Host Key (Left Ctrl)and L does nothing.

How do I confirm the guest additions is installed?

Hello,

take a look under /usr/share/doc/ and see if you have a doc for VMware, if so, You should be able to see what is needed to get your shares working as well as video. I believe I had to manually set the window size to support full screen on my system.

I don't use VM now, so things might have changed.

Okay, so you need to check now if you are a member of the Vboxusers group.

On your host machine, open a terminal and issue the following command:

groups <user>

Where <user> is your username. Mine, for example, is stephen.

So, in my case, it would be groups stephen.

If "vboxusers" is not in the list, issue the following command:

sudo usermod -a -G vboxusers <user>

Then log out of your host desktop session and back in.

Then open a terminal and issue the following command:

groups <user>

You should now see "vboxusers" in the list. If you do, re-open your VM and check if you can use your shared folders and if the resolution is working correctly.

After I do this how do I get access to my shared files? I set up my entire NTFS Data Partition as a shared folder and can't find it in Mavericks, it's not under Shared Folder or anywhere in Mavericks File Manager.

I'm sorry, but that all reads a bit disjointed. To be clear:

Are you saying

  1. you were not in the vboxuser group?
  2. you ran the command to make you a member of the vboxusers group?
  3. you are now in the vboxusers group?
  4. you still cannot access your shared folders from inside the VM despite being a member of the vboxusers group?

Yes, that is what I'm saying.

Thank You.

Okay

I am assuming you logged out of your host desktop and back in as instructed, prior to running your VM, and shared folders was still not working after doing that.

Your next option would be to set up a real network folder on your host and then access it via your network in your VM. To do this, you need to use the Samba network sharing protocol.

You could do it entirely within the samba config file. But, there is an easier way using a GUI Samba tool called system-config-samba with a very small additional edit to the conf file.

  1. Install system-config-samba with the following command in a terminal:

    sudo apt-get install system-config-samba

  2. After the installation has completed and whilst still in the terminal, issue the following command:

    sudo touch /etc/libuser.conf

  3. Whilst still in the terminal, issue the following command:

    sudo system-config-samba

    Samba should now load

  4. Follow the example in the video, below, of how to use the Samba GUI to choose a folder/entire drive and share it on the network. When you are done using system-config-samba, close it (ignore my prevarications in the video on which folder to share. I was trying to share one I have not already shared. You should be, presumably, able to go straight to the one you want to share).

  1. Still following the example in the video, open Caja as a superuser. You can do this from a terminal with the command:

    sudo caja

    Following the example in the video, navigate to the etc/samba folder and open samba.conf and amend the bottom of your new network folder entry as indicated in the video. Then save and close samba.conf. Then close Caja.

  2. Log out of and then back into your host machine and then run your VM and go to its file manager's network locations folder (or wherever they are located in OSX). Hopefully, you should see your newly shared Linux network folder/drive in there.

Thanks, that video helped and I got it to work.