VirtualBox 5.2 Issues

virtualization

#1

In case this helps someone, I just upgraded my 16.04.1-64 system to VirtualBox 5.2.

No doubt about it, the VBoxAdditions ISO that comes with it is just plain flakey on my system. They show a fix here. After it flaked on Debian 9 and Ubuntu-MATE 16.04 guests I decided I’m not even going to try the original ISO anymore.

Definitely an improvement. I should listen to my own advice and never use a first release. :slight_smile: Hope this helps someone.


#2

If anyone else notices Firefox won’t run or causes instability:

Under Display, Turn OFF 3D Acceleration

All my Linux guests on a 16.04 host has this issue - and just when I want to take a good look at Firefox 57.


#3

Summary of this fiasco. I suggest anyone thinking of upgrading to 5.2 hold off. Linux guests are just plain ridiculous. But if you are suffering like me, here’s some things I found on a U-M 16.04 host.

  • Built-in kernel support for Ubuntu (as opposed to VBoxAdditions) works best. You miss features I always want like bidirectional clipboard but stability may be worth it.

  • The use of the 5.2.1 VBoxAdditions ISO suggested on their download page is mixed.

  • You roll the dice trying to use graphical 3D acceleration. One common symptom is Firefox will not run! And not just new version 57 Quantum but any old version. Some incompatibility with 3D acceleration seems likely as we know Mozilla/Firefox has been tweaking for speed every creative way they can for quite a while.

  • Something is very wrong with updating large compressed files - especially kernels where the filesize is 100MB typical. “Unpacking…” takes FOREVER! I timed a kernel update in a 16.04 guest to be 35 minutes!!! No large CPU usage so it’s obviously I/O to the disk is likely very broken.

Of course I welcome any insight to these issues and other findings.


#4

This is not just ridiculous, this is getting beyond ridiculous. Guest additions 5.2.2 in Ubuntu 18.04 VM give me the same problems. I can’t run Firefox, mate-tweak or even glxinfo with 3D acceleration enabled. However, it gets even worse after I turn it off: the system won’t even boot properly.

Removing virtualbox-guest-* packages is a good workaround, it allows kernel’s own vboxvideo and vboxguest modules to load. Though, as mentioned above, they don’t have host/guest clipboard support. :rage:


#5

Yeah… it literally sucks.

LOL! You edited as I was going to mention removing Guest Additions. :grinning:

The upgrade to 5.2.2 is a little better but 3D accel is still not right.

Do you see ridiculous Unpacking… times for big files like kernel updates? I mean really long!


#6

Yeah, I realized I forgot to write about my experience after removing these packages, so I decided to edit the post. :slight_smile:

Unpacking times seem to be the same as always here… Maybe it’s because VirtualBox itself (on the host) is 5.1.30. I didn’t upgrade it to 5.2.


#7

Unpacking times could be I always use synaptic so I see it in the little terminal.

5.1 has the issue too? This only started for me only after going to 5.2. I’m using Oracle’s PPA for 16.04 BTW. The USB extension pack update was rocky 5.2.0 to 5.2.2 as it tried to do its little routine to update it - had to download it.


#8

5.1 is the host VirtualBox version. Only guest additions are 5.2, they’re from Ubuntu 18.04 repos.


#9

Gotcha. I’ve never mismatched VBAdds in that direction. :slight_smile: So this points to 5.2’s Additions as the ultimate source of problems.

I see these issues are acknowledged:

From https://www.virtualbox.org/wiki/Downloads :
Note: The Guest Additions image with the 5.2.2 release still has some known problems with certain Linux distributions when 3D acceleration is enabled. We hope to provide updated builds here when these are fixed.

EDIT: You should just install VBAdds from the 5.1 CD built in. That was working fine.


#10

Yeah, I already thought about it, then I looked at 17.10 repos and got virtualbox-guest-* 5.1.30 from there. They work, should be ok as a temporary solution. :slight_smile:


#11

Ok, the VirtualBox developers stated that 5.2.4 should fix the remaining issues.


#12

Hi @monsta, 5.2.4 has fixed everything except my slow “Unpacking…”. I’ve tried everything easy I can think of and down to more drastic measures.

Before I start reinstalling things on the system I rely on I wanted to be sure it is just me and would appreciate anyone trying a benchmark I established:

I posted this just after trying everything on 5.2.4.


#13

I still stay on 5.1.30 (on host) just in case. :slight_smile:


Virtualbox has newer version in synaptic, why no update?
#14

I’m back with you and glad I did. Debian 9 just updated a kernel and on 5.2.4 it took 37 *&^% minutes. On 5.1.30 it took 2 minutes flat!!!

That particular Debian 9.0 VM does have full VBox Additions from 5.2.4 so it’s not related to that which you saw originally with the other issues.

I suspect it may be a kernel mismatch with the old 4.4.0 version I stick with for other reasons. I can hear a bursting noise on disk access like it’s bit-banging disk I/O when 5.2.4 is sloooowly unpacking things.

And thanks for all your help! :slight_smile: