Virtualbox Full Screen on Dual Display

Was wondering if anyone had an answer to this.

At work I connect my laptop to a secondary monitor for extended desktop. I run Windows 7 in virtualbox for work.

So when I do ctrl-f for fullscreen on my VM it always goes full on my laptop, even if it’s open on the monitor. Does anyone know if there is a way to choose which display it goes fullscreen on?


There is yes. I ran into the same problem in work. In the VM tool bar (of the v!m window itself) you should have an option to choose which display to output too. I can’t point you exactly there because its Saturday morning here and I’m not in work!

Thanks I will dig for it…at least I know where to look now.


Update, finally took the time to look harder and found it in the settings when full screen. Thanks @CGB

1 Like